[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / devil

Annotation of ports/graphics/devil/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2:
        !             3: COMMENT =              full featured cross-platform image library
        !             4:
        !             5: DISTNAME =             DevIL-1.7.8
        !             6: PKGNAME =              ${DISTNAME:L}
        !             7:
        !             8: SHARED_LIBS +=         IL      0.0 #2.0
        !             9: SHARED_LIBS +=                 ILU     0.0 #2.0
        !            10: SHARED_LIBS +=                 ILUT    0.0 #2.0
        !            11:
        !            12: CATEGORIES =           graphics
        !            13:
        !            14: HOMEPAGE =             http://openil.sourceforge.net/
        !            15:
        !            16: #MAINTAINER =          ???
        !            17:
        !            18: # LGPLv2.1
        !            19: PERMIT_PACKAGE_CDROM = Yes
        !            20: PERMIT_PACKAGE_FTP =   Yes
        !            21: PERMIT_DISTFILES_CDROM =Yes
        !            22: PERMIT_DISTFILES_FTP = Yes
        !            23:
        !            24: WANTLIB =              GL GLU ICE SM X11 Xau Xdmcp Xext Xi Xmu Xrandr Xrender \
        !            25:                        Xt c iconv jpeg m pthread pthread-stubs sndio stdc++  \
        !            26:                        usbhid xcb z
        !            27:
        !            28: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=openil/}
        !            29: EXTRACT_SUFX =                 .zip
        !            30:
        !            31: LIB_DEPENDS =          alleg::devel/allegro \
        !            32:                        SDL::devel/sdl \
        !            33:                        glut::graphics/glut \
        !            34:                        Half,Iex,IlmThread,Imath::graphics/ilmbase \
        !            35:                        IlmImf::graphics/openexr \
        !            36:                        jasper::graphics/jasper \
        !            37:                        tiff::graphics/tiff \
        !            38:
        !            39: REGRESS_DEPENDS =      ::shells/bash
        !            40:
        !            41: USE_X11 =              Yes
        !            42: USE_LIBTOOL =          Yes
        !            43: CONFIGURE_STYLE =      gnu
        !            44: CONFIGURE_ARGS +=      --enable-ILU \
        !            45:                        --enable-ILUT \
        !            46:                        --with-examples \
        !            47:                        ${CONFIGURE_SHARED}
        !            48: CONFIGURE_ENV =                LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread" \
        !            49:                        CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include/"
        !            50:
        !            51: #NO_REGRESS =          Yes
        !            52:
        !            53: WRKDIST =              ${WRKDIR}/${DISTNAME:L}
        !            54:
        !            55: post-extract:
        !            56: .for i in configure build-aux/install-sh
        !            57:        chmod a+x ${WRKSRC}/$i
        !            58: .endfor
        !            59:
        !            60: .include <bsd.port.mk>

CVSweb