[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / graphics / cegui

Annotation of ports/graphics/cegui/Makefile, Revision 1.5

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              library providing windowing and widgets for graphics APIs
                      4:
1.4       yason       5: DISTNAME =             CEGUI-0.6.2
1.1       yason       6: PKGNAME =              ${DISTNAME:L}
                      7:
1.5     ! yason       8: SHARED_LIBS +=         CEGUIBase               0.0 #3.0
        !             9: SHARED_LIBS +=         CEGUIFalagardWRBase     0.0 #3.0
        !            10: SHARED_LIBS +=         CEGUILuaScriptModule    0.0 #3.0
        !            11: SHARED_LIBS +=         CEGUIOpenGLRenderer     0.0 #1.0
        !            12: SHARED_LIBS +=         CEGUITGAImageCodec      0.0 #0.0
        !            13: SHARED_LIBS +=         CEGUITinyXMLParser      0.0 #0.0
        !            14: SHARED_LIBS +=         CEGUItoluapp            0.0 #3.0
1.1       yason      15:
                     16: CATEGORIES =           graphics devel
                     17:
                     18: HOMEPAGE =             http://www.cegui.org.uk
                     19:
1.2       yason      20: # MIT
1.1       yason      21: PERMIT_PACKAGE_CDROM = Yes
                     22: PERMIT_PACKAGE_FTP =   Yes
                     23: PERMIT_DISTFILES_CDROM =Yes
                     24: PERMIT_DISTFILES_FTP = Yes
                     25:
1.3       yason      26: WANTLIB =              GL GLU ICE SM X11 Xau Xdmcp Xext Xi Xmu \
1.5     ! yason      27:                        Xt c freetype m pthread pthread-stubs xcb z
1.1       yason      28:
                     29: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=crayzedsgui/}
                     30:
1.2       yason      31: LIB_DEPENDS =          glut.>=3::graphics/glut \
                     32:                        lua.>=5::lang/lua \
                     33:                        pcre.>=2::devel/pcre
1.1       yason      34:
1.2       yason      35: USE_X11 =              Yes
1.1       yason      36: USE_LIBTOOL =          Yes
                     37: CONFIGURE_STYLE =      gnu
1.2       yason      38: CONFIGURE_ARGS =       --disable-expat \
1.3       yason      39:                        --disable-external-glew \
                     40:                        --disable-freeimage \
1.2       yason      41:                        --disable-irrlicht-renderer \
                     42:                        --disable-libxml \
1.3       yason      43:                        --enable-toluacegui \
1.5     ! yason      44:                        --disable-xerces-c \
        !            45:                        ${CONFIGURE_SHARED}
1.1       yason      46:
1.4       yason      47: #MAKE_ENV =
1.2       yason      48: CONFIGURE_ENV +=       CPPLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
1.4       yason      49:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm -pthread -lXi -lXmu"
1.2       yason      50:
                     51: post-patch:
1.4       yason      52: # Find out what prevents to fing GL/glu/h and GL/gl.h when building in Samples
1.2       yason      53:        @perl -pi -e 's|Samples||g' ${WRKSRC}/Makefile.in
1.4       yason      54: #
1.3       yason      55:        @perl -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
1.1       yason      56:
                     57: .include <bsd.port.mk>

CVSweb