[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / geo / viking

File: [local] / ports / geo / viking / Attic / Makefile (download)

Revision 1.2, Fri Sep 18 20:34:03 2009 UTC (14 years, 8 months ago) by yason
Branch: MAIN
Changes since 1.1: +6 -45 lines

update and clean-up

# $OpenBSD$
#ONLY_FOR_ARCHS =	???
#NOT_FOR_ARCHS =	???
#SHARED_ONLY =		???
#COMES_WITH =		???
#BROKEN =		reason

COMMENT =		GPS data management

DISTNAME =		viking-0.9.9

CATEGORIES =		geo x11

HOMEPAGE =		http://apps.sourceforge.net/mediawiki/viking/index.php?title=Main_Page

#MAINTAINER =		???

# GPLv2+
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes \
			Xi Xinerama Xrandr Xrender c crypto expat fontconfig \
			freetype gio-2.0 glib-2.0 glitz gmodule-2.0 gobject-2.0 \
			gthread-2.0 iconv idn intl m pixman-1 png pthread \
			pthread-stubs ssl xcb z

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=viking/}

MODULES = 		textproc/intltool
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
LIB_DEPENDS =		atk-1.0::devel/atk \
			cairo.>=9::graphics/cairo \
			curl.>=13::net/curl \
			gdk-x11-2.0.>=1400::x11/gtk+2 \
			gdk_pixbuf-2.0.>=1400::x11/gtk+2 \
			gps.>=18::misc/gpsd \
			gtk-x11-2.0.>=1400::x11/gtk+2 \
			pango-1.0.>=1800,pangoft2-1.0.>=1800::devel/pango \
			pangocairo-1.0.>=1800::devel/pango

#REGRESS_DEPENDS =	???

USE_X11 =		Yes
USE_GMAKE =		Yes

CONFIGURE_STYLE =	gnu
#CONFIGURE_ARGS +=	--enable-realtime-gps-tracking=no
CONFIGURE_ENV +=	LDFLAGS="-L${LOCALBASE}/lib -pthread"

#NO_REGRESS =		Yes

.include <bsd.port.mk>