[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / geo / viking

Annotation of ports/geo/viking/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2: #ONLY_FOR_ARCHS =      ???
        !             3: #NOT_FOR_ARCHS =       ???
        !             4: #SHARED_ONLY =         ???
        !             5: #COMES_WITH =          ???
        !             6: #BROKEN =              reason
        !             7:
        !             8: COMMENT =              GPS data management
        !             9:
        !            10: DISTNAME =             viking-0.9.8
        !            11:
        !            12: #SHARED_LIBS =         ???
        !            13:
        !            14: CATEGORIES =           geo x11
        !            15:
        !            16: HOMEPAGE =             http://apps.sourceforge.net/mediawiki/viking/index.php?title=Main_Page
        !            17:
        !            18: #MAINTAINER =          ???
        !            19:
        !            20: # GPLv2+
        !            21: PERMIT_PACKAGE_CDROM = Yes
        !            22: PERMIT_PACKAGE_FTP =   Yes
        !            23: PERMIT_DISTFILES_CDROM =Yes
        !            24: PERMIT_DISTFILES_FTP = Yes
        !            25:
        !            26: WANTLIB =              X11 Xau Xcomposite Xcursor Xdamage Xdmcp Xext Xfixes \
        !            27:                        Xi Xinerama Xrandr Xrender c crypto expat fontconfig \
        !            28:                        freetype gio-2.0 glib-2.0 glitz gmodule-2.0 gobject-2.0 \
        !            29:                        gthread-2.0 iconv idn intl m pixman-1 png pthread ssl z
        !            30:
        !            31: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=viking/}
        !            32:
        !            33: # Dependencies
        !            34: #
        !            35: #MODULES =             ???
        !            36: #BUILD_DEPENDS =       ???
        !            37: #RUN_DEPENDS =         ???
        !            38: LIB_DEPENDS =          atk-1.0::devel/atk \
        !            39:                        cairo.>=9::graphics/cairo \
        !            40:                        curl.>=13::net/curl \
        !            41:                        gdk-x11-2.0.>=1400::x11/gtk+2 \
        !            42:                        gdk_pixbuf-2.0.>=1400::x11/gtk+2 \
        !            43:                        gps.>=18::misc/gpsd \
        !            44:                        gtk-x11-2.0.>=1400::x11/gtk+2 \
        !            45:                        pango-1.0.>=1800,pangoft2-1.0.>=1800::devel/pango \
        !            46:                        pangocairo-1.0.>=1800::devel/pango
        !            47: #REGRESS_DEPENDS =     ???
        !            48:
        !            49: #MAKE_FLAGS =          ???
        !            50: #MAKE_ENV =            ???
        !            51: #FAKE_FLAGS =          ???
        !            52: #REGRESS_FLAGS =       ???
        !            53:
        !            54: USE_X11 =              Yes
        !            55: USE_GMAKE =            Yes
        !            56: #USE_LIBTOOL =         Yes
        !            57:
        !            58: CONFIGURE_STYLE =      gnu
        !            59: #CONFIGURE_ARGS +=     --enable-realtime-gps-tracking=no
        !            60: CONFIGURE_ENV +=               LDFLAGS="-L${LOCALBASE}/lib -pthread"
        !            61:
        !            62: #FLAVORS =     1 2 3 a b
        !            63: #FLAVOR ?=
        !            64: # grab multiple choice value
        !            65: #CHOICE = ${FLAVOR:L:Na:Nb}
        !            66: # check that CHOICE is 1 OR 2 OR 3, or error out
        !            67: #.if ${CHOICE} == "1"
        !            68: # code for 1
        !            69: #.elif ${CHOICE} == "2"
        !            70: # code for 2
        !            71: #.elif ${CHOICE} == "3"
        !            72: # code for 3
        !            73: #.else
        !            74: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
        !            75: #.endif
        !            76: # check for switches
        !            77: #.if ${FLAVOR:L:Ma}
        !            78: # code for a
        !            79: #.endif
        !            80: #.if ${FLAVOR:L:Mb}
        !            81: # code for b
        !            82: #.endif
        !            83:
        !            84: #NO_REGRESS =          Yes
        !            85:
        !            86: #CFLAGS =              ???
        !            87: #LDFLAGS =             ???
        !            88: #MAKE_FILE =           ???
        !            89: #PKG_ARCH =            ???
        !            90:
        !            91: #ALL_TARGET =          ???
        !            92: #INSTALL_TARGET =      ???
        !            93: #REGRESS_TARGET =      ???
        !            94:
        !            95: .include <bsd.port.mk>

CVSweb