[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / geo / qmapshack

File: [local] / ports / geo / qmapshack / Attic / Makefile (download)

Revision 1.6, Thu May 7 09:15:41 2020 UTC (4 years ago) by kirby
Branch: MAIN
Changes since 1.5: +1 -1 lines

update to qmapshack-1.10.0

# $OpenBSD: Makefile.template,v 1.73 2016/01/11 09:17:22 sthen Exp $

COMMENT =	map management tool

GH_ACCOUNT = 	Maproom
GH_PROJECT = 	qmapshack
GH_TAGNAME = 	V_1.10.0

CATEGORIES =	geo

HOMEPAGE =	https://github.com/Maproom/qmapshack/wiki

MAINTAINER =	Kirill Bychkov <kirby@openbsd.org>

# GPLv3
PERMIT_PACKAGE =	Yes

WANTLIB += Qt5Core Qt5DBus Qt5Gui Qt5Network Qt5PrintSupport Qt5Script
WANTLIB += Qt5Sql Qt5WebKit Qt5WebKitWidgets Qt5Widgets Qt5Xml
WANTLIB += c gdal m proj pthread quazip5 routino ${COMPILER_LIBCXX}

# C++11
COMPILER = 		base-clang ports-gcc

MODULES =		devel/cmake x11/qt5

RUN_DEPENDS =		devel/desktop-file-utils \
			x11/gtk+3,-guic
LIB_DEPENDS =		archivers/quazip \
			devel/proj \
			geo/gdal,-main \
			geo/routino \
			x11/qt5/qtscript \
			x11/qt5/qtwebkit

CONFIGURE_ARGS = 	-DMAN_INSTALL_DIR=${PREFIX}/man \
			-DCMAKE_CXX_FLAGS=-DACCEPT_USE_OF_DEPRECATED_PROJ_API_H=1

NO_TEST = 		Yes

.include <bsd.port.mk>