[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / geo / navit

Annotation of ports/geo/navit/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2: #ONLY_FOR_ARCHS =      ???
        !             3: #NOT_FOR_ARCHS =       ???
        !             4: #SHARED_ONLY =         ???
        !             5: #COMES_WITH =          ???
        !             6: #BROKEN =              reason
        !             7:
        !             8: COMMENT =              car navigation system with routing engine
        !             9:
        !            10: DISTNAME =             navit-0.1.1
        !            11:
        !            12: #SHARED_LIBS =         ???
        !            13:
        !            14: CATEGORIES =           geo
        !            15:
        !            16: HOMEPAGE =             http://navit.sourceforge.net
        !            17:
        !            18: #MAINTAINER =          ???
        !            19:
        !            20: # GPLv2
        !            21: PERMIT_PACKAGE_CDROM = Yes
        !            22: PERMIT_PACKAGE_FTP =   Yes
        !            23: PERMIT_DISTFILES_CDROM =Yes
        !            24: PERMIT_DISTFILES_FTP = Yes
        !            25:
        !            26: #WANTLIB =             ???
        !            27:
        !            28: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=navit/}
        !            29:
        !            30: MODULES =              textproc/intltool
        !            31: #BUILD_DEPENDS =       ???
        !            32: #RUN_DEPENDS =         ???
        !            33: #LIB_DEPENDS =         ???
        !            34: #REGRESS_DEPENDS =     ???
        !            35:
        !            36: #MAKE_FLAGS =          ???
        !            37: #MAKE_ENV =            ???
        !            38: #FAKE_FLAGS =          ???
        !            39: #REGRESS_FLAGS =       ???
        !            40:
        !            41: #SEPARATE_BUILD =      concurrent  (build simultaneously on all arches)
        !            42: #SEPARATE_BUILD =      simple  (configure/build still recreates files in source)
        !            43: #USE_X11 =             Yes
        !            44: #USE_GMAKE =           Yes
        !            45: # Programs that uses libtool should use this option,
        !            46: # unless there is a really good reason not to.
        !            47: #USE_LIBTOOL =         Yes
        !            48: CONFIGURE_STYLE =      gnu
        !            49: #CONFIGURE_SCRIPT =    ??? (if other than configure)
        !            50: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
        !            51: CONFIGURE_ENV =                CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include"
        !            52:
        !            53: #REGRESS_IS_INTERACTIVE =      Yes
        !            54:
        !            55: #FLAVORS =     1 2 3 a b
        !            56: #FLAVOR ?=
        !            57: # grab multiple choice value
        !            58: #CHOICE = ${FLAVOR:L:Na:Nb}
        !            59: # check that CHOICE is 1 OR 2 OR 3, or error out
        !            60: #.if ${CHOICE} == "1"
        !            61: # code for 1
        !            62: #.elif ${CHOICE} == "2"
        !            63: # code for 2
        !            64: #.elif ${CHOICE} == "3"
        !            65: # code for 3
        !            66: #.else
        !            67: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
        !            68: #.endif
        !            69: # check for switches
        !            70: #.if ${FLAVOR:L:Ma}
        !            71: # code for a
        !            72: #.endif
        !            73: #.if ${FLAVOR:L:Mb}
        !            74: # code for b
        !            75: #.endif
        !            76:
        !            77: #NO_REGRESS =          Yes
        !            78:
        !            79: #CFLAGS =              ???
        !            80: #LDFLAGS =             ???
        !            81: #MAKE_FILE =           ???
        !            82: #PKG_ARCH =            ???
        !            83:
        !            84: #ALL_TARGET =          ???
        !            85: #INSTALL_TARGET =      ???
        !            86: #REGRESS_TARGET =      ???
        !            87:
        !            88: .include <bsd.port.mk>

CVSweb