[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / geo / foxtrotgps

File: [local] / ports / geo / foxtrotgps / Attic / Makefile (download)

Revision 1.1.1.1 (vendor branch), Sun Jan 15 06:08:48 2012 UTC (12 years, 4 months ago) by yason
Branch: yason
CVS Tags: import
Changes since 1.1: +0 -0 lines

initial import

# $OpenBSD$

COMMENT =		lightweight mapping application for use with or without GPS

DISTNAME =		foxtrotgps-1.0.1

CATEGORIES =		geo x11

HOMEPAGE =		http://www.foxtrotgps.org/

MASTER_SITES =		${HOMEPAGE}/releases/

MAINTAINER =		Kirill Bychkov <yason@linklevel.net>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB += GL X11 Xcomposite Xcursor Xdamage Xext Xfixes Xi Xinerama
WANTLIB += Xrandr Xrender atk-1.0 c cairo crypto curl dbus-1 dbus-glib-1
WANTLIB += exif expat ffi fontconfig freetype gconf-2 gdk-x11-2.0
WANTLIB += gdk_pixbuf-2.0 gio-2.0 glade-2.0 glib-2.0 gmodule-2.0 gobject-2.0
WANTLIB += gps gthread-2.0 gtk-x11-2.0 idn m pango-1.0 pangocairo-1.0
WANTLIB += pangoft2-1.0 pcre pixman-1 png pthread pthread-stubs
WANTLIB += sqlite3 ssl xcb xcb-render xcb-shm xml2 z

MODULES = 		devel/gettext \
			lang/python
LIB_DEPENDS =		devel/atk \
			devel/gconf2 \
			devel/libglade2 \
			databases/sqlite3 \
			graphics/libexif \
			misc/gpsd \
			net/curl \
			x11/gtk+2

RUN_DEPENDS = 		devel/desktop-file-utils

CONFIGURE_ENV += 	CPPFLAGS=-I${LOCALBASE}/include \
			LDFLAGS="-L${LOCALBASE}/lib -liconv -lintl"

USE_GMAKE = 	Yes
CONFIGURE_STYLE =	gnu
#AUTOCONF_VERSION =	2.64
NO_REGRESS = 		Yes

MODPY_ADJ_FILES = 	contrib/georss2foxtrotgps-poi
MODPY_RUNDEP = 		No

.include <bsd.port.mk>