[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / geo / foxtrotgps

Annotation of ports/geo/foxtrotgps/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2:
        !             3: COMMENT =              lightweight mapping application for use with or without GPS
        !             4:
        !             5: DISTNAME =             foxtrotgps-1.0.1
        !             6:
        !             7: CATEGORIES =           geo x11
        !             8:
        !             9: HOMEPAGE =             http://www.foxtrotgps.org/
        !            10:
        !            11: MASTER_SITES =         ${HOMEPAGE}/releases/
        !            12:
        !            13: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
        !            14:
        !            15: # GPLv2
        !            16: PERMIT_PACKAGE_CDROM = Yes
        !            17: PERMIT_PACKAGE_FTP =   Yes
        !            18: PERMIT_DISTFILES_CDROM =Yes
        !            19: PERMIT_DISTFILES_FTP = Yes
        !            20:
        !            21: WANTLIB += GL X11 Xcomposite Xcursor Xdamage Xext Xfixes Xi Xinerama
        !            22: WANTLIB += Xrandr Xrender atk-1.0 c cairo crypto curl dbus-1 dbus-glib-1
        !            23: WANTLIB += exif expat ffi fontconfig freetype gconf-2 gdk-x11-2.0
        !            24: WANTLIB += gdk_pixbuf-2.0 gio-2.0 glade-2.0 glib-2.0 gmodule-2.0 gobject-2.0
        !            25: WANTLIB += gps gthread-2.0 gtk-x11-2.0 idn m pango-1.0 pangocairo-1.0
        !            26: WANTLIB += pangoft2-1.0 pcre pixman-1 png pthread pthread-stubs
        !            27: WANTLIB += sqlite3 ssl xcb xcb-render xcb-shm xml2 z
        !            28:
        !            29: MODULES =              devel/gettext \
        !            30:                        lang/python
        !            31: LIB_DEPENDS =          devel/atk \
        !            32:                        devel/gconf2 \
        !            33:                        devel/libglade2 \
        !            34:                        databases/sqlite3 \
        !            35:                        graphics/libexif \
        !            36:                        misc/gpsd \
        !            37:                        net/curl \
        !            38:                        x11/gtk+2
        !            39:
        !            40: RUN_DEPENDS =          devel/desktop-file-utils
        !            41:
        !            42: CONFIGURE_ENV +=       CPPFLAGS=-I${LOCALBASE}/include \
        !            43:                        LDFLAGS="-L${LOCALBASE}/lib -liconv -lintl"
        !            44:
        !            45: USE_GMAKE =    Yes
        !            46: CONFIGURE_STYLE =      gnu
        !            47: #AUTOCONF_VERSION =    2.64
        !            48: NO_REGRESS =           Yes
        !            49:
        !            50: MODPY_ADJ_FILES =      contrib/georss2foxtrotgps-poi
        !            51: MODPY_RUNDEP =                 No
        !            52:
        !            53: .include <bsd.port.mk>

CVSweb