[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / xmoto

File: [local] / ports / games / xmoto / Attic / Makefile (download)

Revision 1.1.1.1 (vendor branch), Sun Nov 30 18:35:25 2008 UTC (15 years, 7 months ago) by yason
Branch: xmoto
CVS Tags: import
Changes since 1.1: +0 -0 lines

should be tested on clean -current

# $OpenBSD$

COMMENT =		challenging 2D motocross platform game

DISTNAME =		xmoto-0.5.0-src
PKGNAME =		xmoto-0.5.0

CATEGORIES =		games

HOMEPAGE =		http://xmoto.tuxfamily.org/

MAINTAINER =		Kirill S. Bychkov <yason@linklevel.net>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		GL GLU X11 c iconv m pthread stdc++ z

MASTER_SITES =		http://download.tuxfamily.org/xmoto/xmoto/0.5.0/

LIB_DEPENDS =		SDL::devel/sdl \
			SDL_mixer::devel/sdl-mixer \
			SDL_net::devel/sdl-net \
			SDL_ttf::devel/sdl-ttf \
			bz2::archivers/bzip2 \
			curl::net/curl \
			jpeg::graphics/jpeg \
			lua::lang/lua \
			png::graphics/png \
			sqlite3::databases/sqlite3

USE_X11 =		Yes
USE_GMAKE =		Yes
CONFIGURE_STYLE =	gnu
CONFIGURE_ENV =		CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I/usr/local/include/libpng"\
			LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
			LIBS="-lGL -lm -pthread"

WRKDIST =		${WRKDIR}/${PKGNAME}

.include <bsd.port.mk>