[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / xmoto

Annotation of ports/games/xmoto/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              challenging 2D motocross platform game
                      4:
                      5: DISTNAME =             xmoto-0.5.0-src
                      6: PKGNAME =              xmoto-0.5.0
                      7:
                      8: CATEGORIES =           games
                      9:
                     10: HOMEPAGE =             http://xmoto.tuxfamily.org/
                     11:
                     12: MAINTAINER =           Kirill S. Bychkov <yason@linklevel.net>
                     13:
                     14: # GPLv2
                     15: PERMIT_PACKAGE_CDROM = Yes
                     16: PERMIT_PACKAGE_FTP =   Yes
                     17: PERMIT_DISTFILES_CDROM =Yes
                     18: PERMIT_DISTFILES_FTP = Yes
                     19:
                     20: WANTLIB =              GL GLU X11 c iconv m pthread stdc++ z
                     21:
                     22: MASTER_SITES =         http://download.tuxfamily.org/xmoto/xmoto/0.5.0/
                     23:
                     24: LIB_DEPENDS =          SDL::devel/sdl \
                     25:                        SDL_mixer::devel/sdl-mixer \
                     26:                        SDL_net::devel/sdl-net \
                     27:                        SDL_ttf::devel/sdl-ttf \
                     28:                        bz2::archivers/bzip2 \
                     29:                        curl::net/curl \
                     30:                        jpeg::graphics/jpeg \
                     31:                        lua::lang/lua \
                     32:                        png::graphics/png \
                     33:                        sqlite3::databases/sqlite3
                     34:
                     35: USE_X11 =              Yes
                     36: USE_GMAKE =            Yes
                     37: CONFIGURE_STYLE =      gnu
                     38: CONFIGURE_ENV =                CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I/usr/local/include/libpng"\
                     39:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
                     40:                        LIBS="-lGL -lm -pthread"
                     41:
                     42: WRKDIST =              ${WRKDIR}/${PKGNAME}
                     43:
                     44: .include <bsd.port.mk>

CVSweb