[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / wyrmsun / data

File: [local] / ports / games / wyrmsun / data / Makefile (download)

Revision 1.2, Sat May 14 11:17:24 2022 UTC (2 years ago) by kirby
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +1 -3 lines

Remove RCS id and small tweaks

COMMENT =	RTS featuring elements of mythology, history and fiction

GH_PROJECT =	Wyrmsun

# If all PERMIT_* are Yes, just setting 'PERMIT_PACKAGE_CDROM=Yes' is enough.
PERMIT_PACKAGE =	Yes

RUN_DEPENDS = 	devel/desktop-file-utils

NO_BUILD =	Yes
NO_TEST =	Yes

PKG_ARCH =	*

post-extract:
	sed -i -e "s,/usr/share/wyrmsun,${PREFIX}/share/wyrmsun,g" \
		${WRKSRC}/linux/wyrmsun.desktop
do-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/wyrmsun/
	cd ${WRKSRC} && find * -type d -exec ${INSTALL_DATA_DIR} \
		"${PREFIX}/share/wyrmsun/{}" \;
	cd ${WRKSRC} && find * -type f -mindepth 1 -exec ${INSTALL_DATA} \
		"{}" "${PREFIX}/share/wyrmsun/{}" \;
	${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
	${INSTALL_DATA} ${WRKSRC}/linux/wyrmsun.desktop \
		${PREFIX}/share/applications/
	${INSTALL_DATA_DIR} ${PREFIX}/share/appdata/
	${INSTALL_DATA} ${WRKSRC}/linux/wyrmsun.appdata.xml \
		${PREFIX}/share/appdata/
	rm -r ${PREFIX}/share/wyrmsun/linux

.include <bsd.port.mk>