[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / wyrmsun / data

File: [local] / ports / games / wyrmsun / data / Makefile (download)

Revision 1.1.1.1 (vendor branch), Tue Dec 5 21:59:24 2017 UTC (6 years, 5 months ago) by kirby
Branch: import
CVS Tags: kirby
Changes since 1.1: +0 -0 lines

import wyrmsun

# $OpenBSD: Makefile.template,v 1.75 2016/03/20 17:19:49 naddy Exp $

COMMENT =	RTS featuring elements of mythology, history and fiction

GH_PROJECT =	Wyrmsun

# If all PERMIT_* are Yes, just setting 'PERMIT_PACKAGE_CDROM=Yes' is enough.
PERMIT_PACKAGE_CDROM =	Yes

RUN_DEPENDS = 	devel/desktop-file-utils

NO_BUILD =	Yes
NO_TEST =	Yes

PKG_ARCH =	*

post-extract:
	sed -i -e "s,/usr/share/wyrmsun,${PREFIX}/share/wyrmsun,g" \
		${WRKSRC}/linux/wyrmsun.desktop
do-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/wyrmsun/
	cd ${WRKSRC} && find * -type d -exec ${INSTALL_DATA_DIR} \
		"${PREFIX}/share/wyrmsun/{}" \;
	cd ${WRKSRC} && find * -type f -mindepth 1 -exec ${INSTALL_DATA} \
		"{}" "${PREFIX}/share/wyrmsun/{}" \;
	${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
	${INSTALL_DATA} ${WRKSRC}/linux/wyrmsun.desktop \
		${PREFIX}/share/applications/
	${INSTALL_DATA_DIR} ${PREFIX}/share/appdata/
	${INSTALL_DATA} ${WRKSRC}/linux/wyrmsun.appdata.xml \
		${PREFIX}/share/appdata/
	rm -r ${PREFIX}/share/wyrmsun/linux

.include <bsd.port.mk>