[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / wyrmsun / data

Annotation of ports/games/wyrmsun/data/Makefile, Revision 1.1.1.1

1.1       kirby       1: # $OpenBSD: Makefile.template,v 1.75 2016/03/20 17:19:49 naddy Exp $
                      2:
                      3: COMMENT =      RTS featuring elements of mythology, history and fiction
                      4:
                      5: GH_PROJECT =   Wyrmsun
                      6:
                      7: # If all PERMIT_* are Yes, just setting 'PERMIT_PACKAGE_CDROM=Yes' is enough.
                      8: PERMIT_PACKAGE_CDROM = Yes
                      9:
                     10: RUN_DEPENDS =  devel/desktop-file-utils
                     11:
                     12: NO_BUILD =     Yes
                     13: NO_TEST =      Yes
                     14:
                     15: PKG_ARCH =     *
                     16:
                     17: post-extract:
                     18:        sed -i -e "s,/usr/share/wyrmsun,${PREFIX}/share/wyrmsun,g" \
                     19:                ${WRKSRC}/linux/wyrmsun.desktop
                     20: do-install:
                     21:        ${INSTALL_DATA_DIR} ${PREFIX}/share/wyrmsun/
                     22:        cd ${WRKSRC} && find * -type d -exec ${INSTALL_DATA_DIR} \
                     23:                "${PREFIX}/share/wyrmsun/{}" \;
                     24:        cd ${WRKSRC} && find * -type f -mindepth 1 -exec ${INSTALL_DATA} \
                     25:                "{}" "${PREFIX}/share/wyrmsun/{}" \;
                     26:        ${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
                     27:        ${INSTALL_DATA} ${WRKSRC}/linux/wyrmsun.desktop \
                     28:                ${PREFIX}/share/applications/
                     29:        ${INSTALL_DATA_DIR} ${PREFIX}/share/appdata/
                     30:        ${INSTALL_DATA} ${WRKSRC}/linux/wyrmsun.appdata.xml \
                     31:                ${PREFIX}/share/appdata/
                     32:        rm -r ${PREFIX}/share/wyrmsun/linux
                     33:
                     34: .include <bsd.port.mk>

CVSweb