[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / violetland

File: [local] / ports / games / violetland / Makefile (download)

Revision 1.10, Sat Apr 16 12:30:19 2016 UTC (8 years ago) by kirby
Branch: MAIN
CVS Tags: HEAD
Changes since 1.9: +1 -1 lines

drop gettext module

# $OpenBSD$

COMMENT =		top view shooting game

GH_ACCOUNT = 		ooxi
GH_PROJECT =		violetland
GH_TAGNAME = 		0.5

CATEGORIES =		games x11

HOMEPAGE =		https://violetland.github.io/

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv3 / Creative Commons 3.0 BY-SA
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB += GL GLU SDL SDL_image SDL_mixer SDL_ttf
WANTLIB += boost_filesystem-mt boost_system-mt c intl m pthread stdc++

MODULES =		devel/cmake
LIB_DEPENDS =		devel/boost \
			devel/sdl-image \
			devel/sdl-mixer \
			devel/sdl-ttf
RUN_DEPENDS = 		devel/desktop-file-utils

NO_TEST =		Yes

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
	${INSTALL_DATA} ${WRKSRC}/violetland.desktop ${PREFIX}/share/applications
	${INSTALL_DATA_DIR} ${PREFIX}/share/pixmaps/
	${INSTALL_DATA} ${WRKSRC}/icon-light.png ${PREFIX}/share/pixmaps/violetland.png

.include <bsd.port.mk>