[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / vcmi

File: [local] / ports / games / vcmi / Attic / Makefile (download)

Revision 1.5, Sat Jun 29 02:56:56 2013 UTC (10 years, 11 months ago) by kirby
Branch: MAIN
Changes since 1.4: +1 -7 lines

fix build

# $OpenBSD$
VMEM_WARNING = 		Yes
#BROKEN = 
SHARED_ONLY = 		Yes

COMMENT =		rewrite of the HoMM3 engine

DISTNAME = 		vcmi-0.93

SHARED_LIBS =		vcmi	0.0 # 0.0

CATEGORIES =		games

HOMEPAGE =		http://forum.vcmi.eu/portal.php

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB += SDL SDL_image SDL_mixer SDL_ttf avcodec avformat avutil
WANTLIB += boost_filesystem-mt boost_program_options-mt boost_system-mt
WANTLIB += boost_thread-mt c m pthread swscale z

MASTER_SITES = 		http://download.vcmi.eu/

MODULES =		devel/cmake gcc4
MODGCC4_ARCHS = 	*
MODGCC4_LANGS +=        c++
RUN_DEPENDS =		devel/desktop-file-utils
LIB_DEPENDS =		devel/boost \
			devel/sdl-image \
			devel/sdl-mixer \
			devel/sdl-ttf \
			graphics/ffmpeg \
			graphics/jpeg \
			graphics/png

# Add -pthread to "enable" boost threading support.
CONFIGURE_ARGS +=	-DCMAKE_CXX_FLAGS=-pthread

NO_TEST =		Yes

.include <bsd.port.mk>