[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / vcmi

File: [local] / ports / games / vcmi / Attic / Makefile (download)

Revision 1.1, Sun Nov 13 21:44:30 2011 UTC (12 years, 7 months ago) by yason
Branch: MAIN

Initial revision

# $OpenBSD$
VMEM_WARNING = 		Yes
#BROKEN = 		CGameHandler.cpp:5226: error: no matching function for call to 'CCreature::getRandomAmount(int ()()) const'

COMMENT =		rewrite of the HoMM3 engine

DISTNAME =		vcmi-0.86

SHARED_LIBS =		vcmi	0.0 # 0.0

CATEGORIES =		games

HOMEPAGE =		http://forum.vcmi.eu/portal.php

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		c freetype m pthread sndio stdc++ usbhid z

MASTER_SITES =		 http://www.linklevel.net/distfiles/

#MODULES =		???
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
LIB_DEPENDS =		audio/libvorbis \
			devel/boost \
			devel/sdl-image \
			devel/sdl-mixer \
			devel/sdl-ttf \
			graphics/ffmpeg \
			graphics/jpeg \
			graphics/png \
			multimedia/libtheora

USE_GMAKE =		Yes
USE_LIBTOOL =		gnu
CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS +=	--disable-debug \
			--with-boost-iostreams=mt \
			--with-boost-filesystem=mt \
			--with-boost-thread=mt \
			--with-boost-system=mt \
			${CONFIGURE_SHARED}
CONFIGURE_ENV +=        CPPFLAGS="-I${LOCALBASE}/include  -I${X11BASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread"

NO_REGRESS =		Yes

#pre-patch:
#	@perl -i -pe 's/\r$$//' ${WRKSRC}/lib/Interprocess.h
pre-configure:
	@perl -pi -e s'|-lpthread|-pthread|g' ${WRKSRC}/lib/Makefile.in

.include <bsd.port.mk>