[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / vcmi

File: [local] / ports / games / vcmi / Attic / Makefile (download)

Revision 1.2, Wed Jun 12 16:01:39 2013 UTC (11 years ago) by kirby
Branch: MAIN
Changes since 1.1: +19 -23 lines

sync with reality

# $OpenBSD$
VMEM_WARNING = 		Yes
#BROKEN = 		/usr/local/lib/gcc/x86_64-unknown-openbsd5.3/4.6.4/../../../../include/c++/4.6.4/bits/stl_list.h:113:71: error: use of deleted function 'std::unique_ptr<_Tp, _Dp>::unique_ptr(const std::unique_ptr<_Tp, _Dp>&) [with _Tp = ILogTarget, _Dp = std::default_delete<ILogTarget>, std::unique_ptr<_Tp, _Dp> = std::unique_ptr<ILogTarget>]'
SHARED_ONLY = 		Yes

COMMENT =		rewrite of the HoMM3 engine

DISTNAME = 		vcmi-0.93

SHARED_LIBS =		vcmi	0.0 # 0.0

CATEGORIES =		games

HOMEPAGE =		http://forum.vcmi.eu/portal.php

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes

WANTLIB =		c freetype m pthread sndio stdc++ usbhid z

MASTER_SITES = 		http://download.vcmi.eu/

MODULES =		devel/cmake gcc4
MODGCC4_ARCHS = 	*
MODGCC4_LANGS +=        c++
#BUILD_DEPENDS =	???
RUN_DEPENDS =		devel/desktop-file-utils
LIB_DEPENDS =		audio/libvorbis \
			devel/boost \
			devel/sdl-image \
			devel/sdl-mixer \
			devel/sdl-ttf \
			graphics/ffmpeg \
			graphics/jpeg \
			graphics/png \
			multimedia/libtheora

#USE_LIBTOOL =		gnu
CONFIGURE_ARGS +=	-DCMAKE_CXX_FLAGS=-pthread
#			--with-boost-iostreams=mt \
#			--with-boost-filesystem=mt \
#			--with-boost-thread=mt \
#			--with-boost-system=mt \
#			${CONFIGURE_SHARED}
#CONFIGURE_ENV +=        CPPFLAGS="-I${LOCALBASE}/include  -I${X11BASE}/include" \
#			LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread"

NO_TEST =		Yes

#pre-patch:
#	@perl -i -pe 's/\r$$//' ${WRKSRC}/lib/Interprocess.h

.include <bsd.port.mk>