[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / vcmi

Annotation of ports/games/vcmi/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2: VMEM_WARNING =                 Yes
                      3: #BROKEN =              CGameHandler.cpp:5226: error: no matching function for call to 'CCreature::getRandomAmount(int ()()) const'
                      4:
                      5: COMMENT =              rewrite of the HoMM3 engine
                      6:
                      7: DISTNAME =             vcmi-0.86
                      8:
                      9: SHARED_LIBS =          vcmi    0.0 # 0.0
                     10:
                     11: CATEGORIES =           games
                     12:
                     13: HOMEPAGE =             http://forum.vcmi.eu/portal.php
                     14:
                     15: #MAINTAINER =          ???
                     16:
                     17: # GPLv2
                     18: PERMIT_PACKAGE_CDROM = Yes
                     19: PERMIT_PACKAGE_FTP =   Yes
                     20: PERMIT_DISTFILES_CDROM =Yes
                     21: PERMIT_DISTFILES_FTP = Yes
                     22:
                     23: WANTLIB =              c freetype m pthread sndio stdc++ usbhid z
                     24:
                     25: MASTER_SITES =          http://www.linklevel.net/distfiles/
                     26:
                     27: #MODULES =             ???
                     28: #BUILD_DEPENDS =       ???
                     29: #RUN_DEPENDS =         ???
                     30: LIB_DEPENDS =          audio/libvorbis \
                     31:                        devel/boost \
                     32:                        devel/sdl-image \
                     33:                        devel/sdl-mixer \
                     34:                        devel/sdl-ttf \
                     35:                        graphics/ffmpeg \
                     36:                        graphics/jpeg \
                     37:                        graphics/png \
                     38:                        multimedia/libtheora
                     39:
                     40: USE_GMAKE =            Yes
                     41: USE_LIBTOOL =          gnu
                     42: CONFIGURE_STYLE =      gnu
                     43: CONFIGURE_ARGS +=      --disable-debug \
                     44:                        --with-boost-iostreams=mt \
                     45:                        --with-boost-filesystem=mt \
                     46:                        --with-boost-thread=mt \
                     47:                        --with-boost-system=mt \
                     48:                        ${CONFIGURE_SHARED}
                     49: CONFIGURE_ENV +=        CPPFLAGS="-I${LOCALBASE}/include  -I${X11BASE}/include" \
                     50:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread"
                     51:
                     52: NO_REGRESS =           Yes
                     53:
                     54: #pre-patch:
                     55: #      @perl -i -pe 's/\r$$//' ${WRKSRC}/lib/Interprocess.h
                     56: pre-configure:
                     57:        @perl -pi -e s'|-lpthread|-pthread|g' ${WRKSRC}/lib/Makefile.in
                     58:
                     59: .include <bsd.port.mk>

CVSweb