[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / ufoai / base

Annotation of ports/games/ufoai/base/Makefile, Revision 1.7

1.1       yason       1: # $OpenBSD$
                      2:
1.3       yason       3: COMMENT-main =         squad-based tactical strategy game
                      4: COMMENT-editor =       UFO:AI map editor
1.1       yason       5:
                      6: V =                    2.3.1
                      7: DISTNAME =             ufoai-${V}-source
1.3       yason       8: PKGNAME-main =         ${DISTNAME:S/-source//}
                      9: PKGNAME-editor =       uforadiant-${V}
1.1       yason      10:
1.3       yason      11: EXTRACT_SUFX =         .tar.bz2
                     12:
1.5       yason      13: MULTI_PACKAGES =       -main -editor
1.3       yason      14:
                     15: WANTLIB += GL SDL SDL_image c jpeg m ogg png pthread tiff vorbis vorbisfile z
1.1       yason      16:
1.3       yason      17: WANTLIB-main += FLAC SDL_mixer SDL_ttf crypto curl curses iconv idn intl
                     18: WANTLIB-main += mikmod smpeg ssl theora xvidcore ${WANTLIB}
                     19:
                     20: WANTLIB-editor += GLU ICE SM X11 Xau Xcomposite Xcursor Xdamage Xdmcp
                     21: WANTLIB-editor += Xext Xfixes Xi Xinerama Xmu Xrandr Xrender Xt Xxf86vm
                     22: WANTLIB-editor += atk-1.0 cairo drm expat fontconfig freetype gdk-x11-2.0
                     23: WANTLIB-editor += gdk_pixbuf-2.0 gdkglext-x11-1.0 gio-2.0 glib-2.0 gmodule-2.0
                     24: WANTLIB-editor += gobject-2.0 gthread-2.0 gtk-x11-2.0 gtkglext-x11-1.0
                     25: WANTLIB-editor += gtksourceview-2.0 openal pango-1.0 pangocairo-1.0 pangoft2-1.0
                     26: WANTLIB-editor += pangox-1.0 pixman-1 pthread-stubs sndio stdc++ xcb
                     27: WANTLIB-editor += xcb-render xcb-shm xml2 ${WANTLIB}
1.1       yason      28:
                     29: MODULES =              devel/gettext
1.3       yason      30:
                     31: RUN_DEPENDS =          games/ufoai/data \
                     32:                        devel/desktop-file-utils
                     33:
                     34: LIB_DEPENDS-main =     devel/sdl-image \
1.1       yason      35:                        devel/sdl-mixer \
                     36:                        devel/sdl-ttf \
                     37:                        devel/libexecinfo \
                     38:                        graphics/jpeg \
                     39:                        graphics/png \
                     40:                        multimedia/libtheora \
                     41:                        multimedia/xvidcore \
                     42:                        net/curl \
                     43:                        ${MODGETTEXT_LIB_DEPENDS}
1.3       yason      44:
                     45: LIB_DEPENDS-editor =   audio/libvorbis \
                     46:                        audio/openal \
                     47:                        devel/sdl-image \
                     48:                        x11/gtkglext \
                     49:                        x11/gtksourceview
1.1       yason      50:
                     51: USE_GMAKE =            Yes
                     52: MAKE_FLAGS +=          CFLAGS='-DHAVE_CONFIG_H -Wall -pipe -ansi' \
                     53:                        ${CONFIGURE_ENV}
1.2       yason      54: AUTOCONF_VERSION =     2.67
1.1       yason      55: AUTOMAKE_VERSION =     1.9
                     56: CONFIGURE_STYLE =      autoconf automake
1.2       yason      57: CONFIGURE_ARGS =       --enable-release=yes \
1.3       yason      58:                        --enable-ufo2map \
                     59:                        --enable-uforadiant \
                     60:                        --disable-tests
1.1       yason      61:
                     62: CONFIGURE_ENV +=       CFLAGS="-pthread" \
                     63:                        CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include -I${LOCALBASE}/include/libpng" \
                     64:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -liconv"
                     65:
1.7     ! yason      66: NO_REGRESS =           Yes
        !            67:
1.3       yason      68: ALL_TARGET =           all uforadiant
1.1       yason      69: INSTALL_TARGET =       install_exec
                     70:
                     71: post-extract:
1.3       yason      72:        ${INSTALL_DATA_DIR} ${WRKSRC}/base
1.1       yason      73:
                     74: post-patch:
                     75:        perl -pi -e 's,/usr/share/games/,${PREFIX}/share/,g' ${WRKSRC}/debian/*.6
                     76:        perl -pi -e 's,/usr/games/,${PREFIX}/bin/,g' ${WRKSRC}/debian/*.desktop
                     77:
                     78: pre-configure:
                     79:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
                     80:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} aclocal
                     81:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
                     82:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoconf
                     83:
                     84: post-install:
                     85:        ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/ufoai
1.6       yason      86:        ${INSTALL_DATA} ${WRKSRC}/LICENSES ${PREFIX}/share/ufoai
1.3       yason      87:        ${INSTALL_MAN} ${WRKSRC}/debian/*.6 ${PREFIX}/man/man6
1.1       yason      88:        ${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
1.3       yason      89:        ${INSTALL_DATA} ${WRKSRC}/debian/*.desktop ${PREFIX}/share/applications
                     90:        ${INSTALL_DATA_DIR} ${PREFIX}/share/ufoai/radiant/
                     91:        cd ${WRKSRC}/radiant && find * -type d -exec ${INSTALL_DATA_DIR} \
                     92:                "${PREFIX}/share/ufoai/radiant/{}" \;
1.4       yason      93:        cd ${WRKSRC}/radiant && find * -type f -mindepth 1 -exec ${INSTALL_DATA} \
1.3       yason      94:                "{}" "${PREFIX}/share/ufoai/radiant/{}" \;
1.4       yason      95:        ${INSTALL_PROGRAM} ${WRKSRC}/radiant/uforadiant ${PREFIX}/share/ufoai/radiant/
1.1       yason      96:
                     97: .include <bsd.port.mk>

CVSweb