[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / ufoai / base

Annotation of ports/games/ufoai/base/Makefile, Revision 1.10

1.1       yason       1: # $OpenBSD$
                      2:
1.8       yason       3: SHARED_ONLY =          Yes
                      4:
1.3       yason       5: COMMENT-main =         squad-based tactical strategy game
                      6: COMMENT-editor =       UFO:AI map editor
1.1       yason       7:
                      8: V =                    2.3.1
                      9: DISTNAME =             ufoai-${V}-source
1.3       yason      10: PKGNAME-main =         ${DISTNAME:S/-source//}
                     11: PKGNAME-editor =       uforadiant-${V}
1.1       yason      12:
1.3       yason      13: EXTRACT_SUFX =         .tar.bz2
                     14:
1.5       yason      15: MULTI_PACKAGES =       -main -editor
1.3       yason      16:
1.10    ! yason      17: WANTLIB += GL SDL SDL_image c jpeg m ogg png pthread tiff
        !            18: WANTLIB += vorbis vorbisfile z
1.1       yason      19:
1.10    ! yason      20: WANTLIB-main += FLAC SDL_mixer SDL_ttf crypto curl curses
        !            21: WANTLIB-main += iconv idn intl mikmod smpeg ssl theora
        !            22: WANTLIB-main += xvidcore ${WANTLIB}
        !            23:
        !            24: WANTLIB-editor += GLU ICE SM X11 Xau Xcomposite Xcursor Xdamage
        !            25: WANTLIB-editor += Xdmcp Xext Xfixes Xi Xinerama Xmu Xrandr Xrender
        !            26: WANTLIB-editor += Xt Xxf86vm atk-1.0 cairo drm expat fontconfig
        !            27: WANTLIB-editor += freetype gdk-x11-2.0 gdk_pixbuf-2.0 gdkglext-x11-1.0
        !            28: WANTLIB-editor += gio-2.0 glib-2.0 gmodule-2.0 gobject-2.0 gthread-2.0
        !            29: WANTLIB-editor += gtk-x11-2.0 gtkglext-x11-1.0 gtksourceview-2.0
        !            30: WANTLIB-editor += openal pango-1.0 pangocairo-1.0 pangoft2-1.0
1.3       yason      31: WANTLIB-editor += pangox-1.0 pixman-1 pthread-stubs sndio stdc++ xcb
                     32: WANTLIB-editor += xcb-render xcb-shm xml2 ${WANTLIB}
1.1       yason      33:
                     34: MODULES =              devel/gettext
1.3       yason      35:
1.8       yason      36: BUILD_DEPENDS =        ${MODGNU_AUTOCONF_DEPENDS} \
                     37:                        ${MODGNU_AUTOMAKE_DEPENDS}
                     38:
                     39: RUN_DEPENDS =          games/ufoai/data>=${V} \
1.3       yason      40:                        devel/desktop-file-utils
                     41:
                     42: LIB_DEPENDS-main =     devel/sdl-image \
1.1       yason      43:                        devel/sdl-mixer \
                     44:                        devel/sdl-ttf \
                     45:                        devel/libexecinfo \
                     46:                        graphics/jpeg \
                     47:                        graphics/png \
                     48:                        multimedia/libtheora \
                     49:                        multimedia/xvidcore \
                     50:                        net/curl \
                     51:                        ${MODGETTEXT_LIB_DEPENDS}
1.3       yason      52:
                     53: LIB_DEPENDS-editor =   audio/libvorbis \
                     54:                        audio/openal \
                     55:                        devel/sdl-image \
                     56:                        x11/gtkglext \
                     57:                        x11/gtksourceview
1.1       yason      58:
                     59: USE_GMAKE =            Yes
1.8       yason      60: MAKE_FLAGS +=          ${CONFIGURE_ENV}
                     61:
                     62: CFLAGS +=              -pthread
                     63:
1.2       yason      64: AUTOCONF_VERSION =     2.67
1.1       yason      65: AUTOMAKE_VERSION =     1.9
1.8       yason      66: CONFIGURE_STYLE =      gnu
1.2       yason      67: CONFIGURE_ARGS =       --enable-release=yes \
1.3       yason      68:                        --enable-ufo2map \
                     69:                        --enable-uforadiant \
                     70:                        --disable-tests
1.1       yason      71:
1.8       yason      72: CONFIGURE_ENV +=       CFLAGS="${CFLAGS}" \
                     73:                        CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include \
                     74:                                -I${LOCALBASE}/include/libpng" \
1.1       yason      75:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -liconv"
                     76:
1.7       yason      77: NO_REGRESS =           Yes
                     78:
1.3       yason      79: ALL_TARGET =           all uforadiant
1.1       yason      80: INSTALL_TARGET =       install_exec
                     81:
                     82: post-extract:
1.9       yason      83:        mkdir -p ${WRKSRC}/base/{maps,models}
1.1       yason      84:
1.10    ! yason      85: pre-configure:
1.1       yason      86:        perl -pi -e 's,/usr/share/games/,${PREFIX}/share/,g' ${WRKSRC}/debian/*.6
                     87:        perl -pi -e 's,/usr/games/,${PREFIX}/bin/,g' ${WRKSRC}/debian/*.desktop
                     88:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
                     89:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} aclocal
                     90:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
                     91:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoconf
                     92:
                     93: post-install:
                     94:        ${INSTALL_DATA} ${WRKSRC}/COPYING ${PREFIX}/share/ufoai
1.6       yason      95:        ${INSTALL_DATA} ${WRKSRC}/LICENSES ${PREFIX}/share/ufoai
1.3       yason      96:        ${INSTALL_MAN} ${WRKSRC}/debian/*.6 ${PREFIX}/man/man6
1.1       yason      97:        ${INSTALL_DATA_DIR} ${PREFIX}/share/applications/
1.3       yason      98:        ${INSTALL_DATA} ${WRKSRC}/debian/*.desktop ${PREFIX}/share/applications
                     99:        ${INSTALL_DATA_DIR} ${PREFIX}/share/ufoai/radiant/
                    100:        cd ${WRKSRC}/radiant && find * -type d -exec ${INSTALL_DATA_DIR} \
                    101:                "${PREFIX}/share/ufoai/radiant/{}" \;
1.4       yason     102:        cd ${WRKSRC}/radiant && find * -type f -mindepth 1 -exec ${INSTALL_DATA} \
1.3       yason     103:                "{}" "${PREFIX}/share/ufoai/radiant/{}" \;
1.10    ! yason     104:        ${INSTALL_PROGRAM} ${WRKSRC}/radiant/uforadiant \
        !           105:                ${PREFIX}/share/ufoai/radiant/
1.1       yason     106:
                    107: .include <bsd.port.mk>

CVSweb