[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / spring

File: [local] / ports / games / spring / Attic / Makefile (download)

Revision 1.3, Sun Sep 20 08:24:23 2009 UTC (14 years, 8 months ago) by yason
Branch: MAIN
Changes since 1.2: +4 -2 lines

add LIB_DEPENDS, comment as BROKEN

# $OpenBSD$
#ONLY_FOR_ARCHS =	???
#NOT_FOR_ARCHS =	???
#SHARED_ONLY =		???
#COMES_WITH =		???
BROKEN =		needs cmake 2.6

COMMENT =		powerful free RTS engine

DISTNAME =		spring_0.80.4.1_src
PKGNAME =		${DISTNAME:S/_/-/:S/_src//}

#SHARED_LIBS =		???

CATEGORIES =		games

HOMEPAGE =		http://springrts.com/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

#WANTLIB =		???

MASTER_SITES =		http://springrts.com/dl/

MODULES =		devel/cmake
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
LIB_DEPENDS =		::audio/libogg \
			::audio/libvorbis \
			::audio/openal-soft \
			::devel/boost \
			::devel/sdl \
			::graphics/devil \
			::graphics/glew
#REGRESS_DEPENDS =	???

#MAKE_FLAGS =		???
#MAKE_ENV =		???
#FAKE_FLAGS =		???
#REGRESS_FLAGS =	???

USE_X11 =		Yes
#USE_LIBTOOL =		Yes
#CONFIGURE_ARGS +=	${CONFIGURE_SHARED}
#CONFIGURE_ENV =	???

#NO_REGRESS =		Yes

#CFLAGS =		???
#LDFLAGS =		???
WRKDIST =		${WRKDIR}/${DISTNAME:S/_src//}

#ALL_TARGET =		???
#INSTALL_TARGET =	???
#REGRESS_TARGET =	???

.include <bsd.port.mk>