[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / spring

Annotation of ports/games/spring/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD: Makefile.template,v 1.55 2008/08/23 15:28:00 ajacoutot Exp $
        !             2: #ONLY_FOR_ARCHS =      ???
        !             3: #NOT_FOR_ARCHS =       ???
        !             4: #SHARED_ONLY =         ???
        !             5: #COMES_WITH =          ???
        !             6: #BROKEN =              reason
        !             7:
        !             8: COMMENT =              powerful free RTS engine
        !             9: # COMMENT-foo =                ???     for multi packages
        !            10:
        !            11: DISTNAME =             spring_0.80.4.1_src
        !            12: PKGNAME =              ${DISTNAME:S/_/-/:S/_src//}
        !            13:
        !            14: # for any port that create shared libraries.
        !            15: # both libtool and cmake handle this automatically.
        !            16: # for libtool-based ports, have a look at WRKBUILD/shared_libs.log
        !            17: #SHARED_LIBS =         ???
        !            18:
        !            19: CATEGORIES =           games
        !            20:
        !            21: #HOMEPAGE =            ???     URL
        !            22:
        !            23: #MAINTAINER =          ???
        !            24:
        !            25: # In case of GPL, version number must be appended (e.g. v2, v2+, v3).
        !            26: #PERMIT_PACKAGE_CDROM =        Yes | Reason if No
        !            27: #PERMIT_PACKAGE_FTP =  Yes | Reason if No
        !            28: #PERMIT_DISTFILES_CDROM =Yes | Reason if No
        !            29: #PERMIT_DISTFILES_FTP =        Yes | Reason if No
        !            30:
        !            31: #WANTLIB =             ???
        !            32:
        !            33: MASTER_SITES =         http://springrts.com/dl/
        !            34: #MASTER_SITES =                ${MASTER_SITE_foo:=subdir/}
        !            35: # if more master sites are needed...
        !            36: #MASTER_SITES0 =
        !            37: # ...
        !            38: #DISTFILES =           ???
        !            39: #EXTRACT_ONLY =                ???
        !            40: #EXTRACT_SUFX =                .tar.Z
        !            41:
        !            42: #DIST_SUBDIR =         ???
        !            43:
        !            44: # PATCHFILES are also retrieved from MASTER_SITES*
        !            45: #PATCHFILES =          ???
        !            46: #PATCH_DIST_STRIP =    -p0
        !            47:
        !            48: MODULES =              devel/cmake
        !            49: #BUILD_DEPENDS =       ???
        !            50: #RUN_DEPENDS =         ???
        !            51: #LIB_DEPENDS =         ???
        !            52: #REGRESS_DEPENDS =     ???
        !            53:
        !            54: #MAKE_FLAGS =          ???
        !            55: #MAKE_ENV =            ???
        !            56: #FAKE_FLAGS =          ???
        !            57: #REGRESS_FLAGS =       ???
        !            58:
        !            59: # build/configuration variables
        !            60: #
        !            61: #SEPARATE_BUILD =      concurrent  (build simultaneously on all arches)
        !            62: #SEPARATE_BUILD =      simple  (configure/build still recreates files in source)
        !            63: #USE_X11 =             Yes
        !            64: #USE_GMAKE =           Yes
        !            65: # Programs that uses libtool should use this option,
        !            66: # unless there is a really good reason not to.
        !            67: #USE_LIBTOOL =         Yes
        !            68: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
        !            69: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
        !            70: #        Module::Build Build.PL)
        !            71: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
        !            72: #        sysconfdir), (dest: add DESTDIR, does not handle it),
        !            73: #        (autoconf: needed by port, implies gnu)
        !            74: #      XXX: cygnus products do NOT use autoconf for making the main
        !            75: #              configure from configure.in
        !            76: #        imake [noman]: port uses imake for configuration.
        !            77: #        (noman: no man page installation)
        !            78: #        simple: port has its own configure script
        !            79: #CONFIGURE_STYLE =
        !            80: #CONFIGURE_SCRIPT =    ??? (if other than configure)
        !            81: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
        !            82: #CONFIGURE_ENV =       ???
        !            83:
        !            84: #
        !            85: #FLAVORS =     1 2 3 a b
        !            86: #FLAVOR ?=
        !            87: # grab multiple choice value
        !            88: #CHOICE = ${FLAVOR:L:Na:Nb}
        !            89: # check that CHOICE is 1 OR 2 OR 3, or error out
        !            90: #.if ${CHOICE} == "1"
        !            91: #.elif ${CHOICE} == "2"
        !            92: # code for 2
        !            93: #.elif ${CHOICE} == "3"
        !            94: # code for 3
        !            95: #.else
        !            96: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
        !            97: #.endif
        !            98: # check for switches
        !            99: #.if ${FLAVOR:L:Ma}
        !           100: # code for a
        !           101: #.endif
        !           102: #.if ${FLAVOR:L:Mb}
        !           103: # code for b
        !           104: #.endif
        !           105:
        !           106: #NO_REGRESS =          Yes
        !           107:
        !           108: #CFLAGS =              ???
        !           109: #LDFLAGS =             ???
        !           110: #MAKE_FILE =           ???
        !           111: #PKG_ARCH =            ???
        !           112: WRKDIST =              ${WRKDIR}/${DISTNAME:S/_src//}
        !           113: #WRKSRC =              ??? if other than ${WRKDIST}
        !           114: #WRKBUILD =            ??? if other than ${WRKSRC}
        !           115: #WRKCONF =             ??? if other than ${WRKBUILD}
        !           116:
        !           117: #ALL_TARGET =          ???
        !           118: #INSTALL_TARGET =      ???
        !           119: #REGRESS_TARGET =      ???
        !           120:
        !           121: .include <bsd.port.mk>

CVSweb