[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / motogt

Annotation of ports/games/motogt/Makefile, Revision 1.2

1.1       yason       1: # $OpenBSD$
                      2: #BROKEN =              coredump on track loading
                      3:
1.2     ! yason       4: COMMENT =              2D top-viewed moto racing game
1.1       yason       5:
                      6: DISTNAME =             MotoGT-20110505
                      7: PKGNAME =              ${DISTNAME:L}
                      8:
                      9: CATEGORIES =           games x11
                     10:
                     11: HOMEPAGE =             http://motogt.sourceforge.net/
                     12:
                     13: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
                     14:
1.2     ! yason      15: # GPL/CC-BY-SA
1.1       yason      16: PERMIT_PACKAGE_CDROM = Yes
                     17: PERMIT_PACKAGE_FTP =   Yes
                     18: PERMIT_DISTFILES_CDROM =Yes
                     19: PERMIT_DISTFILES_FTP = Yes
                     20:
                     21: WANTLIB += GL c m png pthread sfml-audio sfml-graphics sfml-system
                     22: WANTLIB += sfml-window stdc++
                     23:
                     24: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=motogt/}
                     25: EXTRACT_SUFX =         .zip
                     26:
                     27: #RUN_DEPENDS =         ???
                     28: LIB_DEPENDS =          devel/sfml \
                     29:                        graphics/png
                     30:
                     31: #MAKE_FLAGS =          ???
                     32: #MAKE_ENV =            ???
                     33: #FAKE_FLAGS =          ???
                     34:
                     35: USE_GMAKE =            Yes
                     36:
                     37: NO_REGRESS =           Yes
                     38:
                     39: #CFLAGS =              ???
                     40: #LDFLAGS =             ???
                     41: MAKE_FILE =            Makefile.lnx
                     42: WRKDIST =              ${WRKDIR}/MotoGT
                     43: WRKSRC =               ${WRKDIST}/src
                     44:
                     45: do-install:
                     46:        ${INSTALL_DATA_DIR} ${PREFIX}/share/motogt
                     47:        ${INSTALL_PROGRAM} ${WRKDIST}/MotoGT.bin ${PREFIX}/share/motogt/
                     48: #      ${INSTALL_SCRIPT} ${WRKDIR}/motogt ${PREFIX}/bin/
                     49:        cd ${WRKDIST} && pax -rw ./data ${PREFIX}/share/motogt/
                     50:
                     51: .include <bsd.port.mk>

CVSweb