[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / motogt

Annotation of ports/games/motogt/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD$
                      2: #BROKEN =              coredump on track loading
                      3:
                      4: COMMENT =              ???
                      5: # COMMENT-foo =                ???     for multi packages
                      6:
                      7: DISTNAME =             MotoGT-20110505
                      8: PKGNAME =              ${DISTNAME:L}
                      9:
                     10: CATEGORIES =           games x11
                     11:
                     12: HOMEPAGE =             http://motogt.sourceforge.net/
                     13:
                     14: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
                     15:
                     16: # In case of GPL, version number must be appended (e.g. v2, v2+, v3).
                     17: PERMIT_PACKAGE_CDROM = Yes
                     18: PERMIT_PACKAGE_FTP =   Yes
                     19: PERMIT_DISTFILES_CDROM =Yes
                     20: PERMIT_DISTFILES_FTP = Yes
                     21:
                     22: WANTLIB += GL c m png pthread sfml-audio sfml-graphics sfml-system
                     23: WANTLIB += sfml-window stdc++
                     24:
                     25: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=motogt/}
                     26: EXTRACT_SUFX =         .zip
                     27:
                     28: #RUN_DEPENDS =         ???
                     29: LIB_DEPENDS =          devel/sfml \
                     30:                        graphics/png
                     31:
                     32: #MAKE_FLAGS =          ???
                     33: #MAKE_ENV =            ???
                     34: #FAKE_FLAGS =          ???
                     35:
                     36: USE_GMAKE =            Yes
                     37:
                     38: NO_REGRESS =           Yes
                     39:
                     40: #CFLAGS =              ???
                     41: #LDFLAGS =             ???
                     42: MAKE_FILE =            Makefile.lnx
                     43: WRKDIST =              ${WRKDIR}/MotoGT
                     44: WRKSRC =               ${WRKDIST}/src
                     45:
                     46: do-install:
                     47:        ${INSTALL_DATA_DIR} ${PREFIX}/share/motogt
                     48:        ${INSTALL_PROGRAM} ${WRKDIST}/MotoGT.bin ${PREFIX}/share/motogt/
                     49: #      ${INSTALL_SCRIPT} ${WRKDIR}/motogt ${PREFIX}/bin/
                     50:        cd ${WRKDIST} && pax -rw ./data ${PREFIX}/share/motogt/
                     51:
                     52: .include <bsd.port.mk>

CVSweb