[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / megaglest / base

File: [local] / ports / games / megaglest / base / Attic / Makefile (download)

Revision 1.3, Mon Aug 1 05:24:29 2011 UTC (12 years, 10 months ago) by yason
Branch: MAIN
Changes since 1.2: +10 -10 lines

update to megaglest-3.5.2.4

# $OpenBSD$

# TODO: fix build of editor, etc
#BROKEN = 		broken due png update

COMMENT =		open source 3D-real-time strategy game

DISTNAME =		megaglest-source-3.5.2.4
PKGNAME =		${DISTNAME:S/source-//}

# GPLv3
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB += GL GLU ICE SDL SM X11 Xext c crypto curl idn jpeg lua m
WANTLIB += ogg openal png pthread ssl stdc++ vorbis vorbisfile
WANTLIB += xerces-c z

EXTRACT_SUFX =		.tar.xz

MODULES =		devel/cmake
LIB_DEPENDS =		audio/libvorbis \
			audio/openal \
			devel/libidn \
			devel/sdl \
			graphics/jpeg \
			graphics/png \
			lang/lua \
			net/curl \
			textproc/xerces-c
RUN_DEPENDS = 		games/megaglest/data
SEPARATE_BUILD =	simple
CONFIGURE_ARGS +=	-DCMAKE_BUILD_TYPE=RELEASE \
			-DWANT_SVN_STAMP=OFF

NO_REGRESS =		Yes

WRKDIST = 		${WRKDIR}/${PKGNAME}

#do-install:
#	${INSTALL_DATA_DIR} ${PREFIX}/share/megaglest/
#	${INSTALL_DATA} ${WRKSRC}/glest.ini ${PREFIX}/share/megaglest/

.include <bsd.port.mk>