[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / megaglest / base

Annotation of ports/games/megaglest/base/Makefile, Revision 1.7

1.1       yason       1: # $OpenBSD$
                      2:
                      3: COMMENT =              open source 3D-real-time strategy game
                      4:
1.3       yason       5: DISTNAME =             megaglest-source-3.5.2.4
1.1       yason       6: PKGNAME =              ${DISTNAME:S/source-//}
                      7:
                      8: # GPLv3
                      9: PERMIT_PACKAGE_CDROM = Yes
                     10: PERMIT_PACKAGE_FTP =   Yes
                     11: PERMIT_DISTFILES_CDROM =Yes
                     12: PERMIT_DISTFILES_FTP = Yes
                     13:
1.3       yason      14: WANTLIB += GL GLU ICE SDL SM X11 Xext c crypto curl idn jpeg lua m
1.1       yason      15: WANTLIB += ogg openal png pthread ssl stdc++ vorbis vorbisfile
                     16: WANTLIB += xerces-c z
                     17:
1.3       yason      18: EXTRACT_SUFX =         .tar.xz
1.1       yason      19:
                     20: MODULES =              devel/cmake
                     21: LIB_DEPENDS =          audio/libvorbis \
                     22:                        audio/openal \
                     23:                        devel/libidn \
                     24:                        devel/sdl \
                     25:                        graphics/jpeg \
                     26:                        graphics/png \
                     27:                        lang/lua \
1.3       yason      28:                        net/curl \
1.1       yason      29:                        textproc/xerces-c
1.5       yason      30: RUN_DEPENDS =          devel/desktop-file-utils \
                     31:                        games/megaglest/data
1.7     ! yason      32:
1.2       yason      33: CONFIGURE_ARGS +=      -DCMAKE_BUILD_TYPE=RELEASE \
                     34:                        -DWANT_SVN_STAMP=OFF
1.1       yason      35:
                     36: NO_REGRESS =           Yes
                     37:
1.3       yason      38: WRKDIST =              ${WRKDIR}/${PKGNAME}
                     39:
1.1       yason      40: .include <bsd.port.mk>

CVSweb