[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / megaglest / base

Annotation of ports/games/megaglest/base/Makefile, Revision 1.5

1.1       yason       1: # $OpenBSD$
                      2:
                      3: # TODO: fix build of editor, etc
1.3       yason       4: #BROKEN =              broken due png update
1.1       yason       5:
                      6: COMMENT =              open source 3D-real-time strategy game
                      7:
1.3       yason       8: DISTNAME =             megaglest-source-3.5.2.4
1.1       yason       9: PKGNAME =              ${DISTNAME:S/source-//}
                     10:
                     11: # GPLv3
                     12: PERMIT_PACKAGE_CDROM = Yes
                     13: PERMIT_PACKAGE_FTP =   Yes
                     14: PERMIT_DISTFILES_CDROM =Yes
                     15: PERMIT_DISTFILES_FTP = Yes
                     16:
1.3       yason      17: WANTLIB += GL GLU ICE SDL SM X11 Xext c crypto curl idn jpeg lua m
1.1       yason      18: WANTLIB += ogg openal png pthread ssl stdc++ vorbis vorbisfile
                     19: WANTLIB += xerces-c z
                     20:
1.3       yason      21: EXTRACT_SUFX =         .tar.xz
1.1       yason      22:
                     23: MODULES =              devel/cmake
                     24: LIB_DEPENDS =          audio/libvorbis \
                     25:                        audio/openal \
                     26:                        devel/libidn \
                     27:                        devel/sdl \
                     28:                        graphics/jpeg \
                     29:                        graphics/png \
                     30:                        lang/lua \
1.3       yason      31:                        net/curl \
1.1       yason      32:                        textproc/xerces-c
1.5     ! yason      33: RUN_DEPENDS =          devel/desktop-file-utils \
        !            34:                        games/megaglest/data
1.1       yason      35: SEPARATE_BUILD =       simple
1.2       yason      36: CONFIGURE_ARGS +=      -DCMAKE_BUILD_TYPE=RELEASE \
                     37:                        -DWANT_SVN_STAMP=OFF
1.1       yason      38:
                     39: NO_REGRESS =           Yes
                     40:
1.3       yason      41: WRKDIST =              ${WRKDIR}/${PKGNAME}
                     42:
1.1       yason      43: .include <bsd.port.mk>

CVSweb