[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / maxr

File: [local] / ports / games / maxr / Makefile (download)

Revision 1.6, Sun Aug 15 21:01:41 2010 UTC (13 years, 9 months ago) by yason
Branch: MAIN
Changes since 1.5: +1 -2 lines

move to the new WANTLIB

# $OpenBSD$

COMMENT =		M.A.X clone

DISTNAME =		maxr-0.2.6

CATEGORIES =		games x11

HOMEPAGE =		http://www.maxthegame.de

MAINTAINER =		Kirill Bychkov <yason@linklevel.net>

# GPL
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		FLAC c m iconv pthread sndio stdc++ usbhid

MASTER_SITES =		http://www.maxr.org/downloads/

LIB_DEPENDS =		SDL::devel/sdl \
			SDL_mixer.>=4::devel/sdl-mixer \
			SDL_net::devel/sdl-net \
			mikmod::audio/libmikmod \
			ogg::audio/libogg \
			smpeg::devel/smpeg \
			vorbis,vorbisfile::audio/libvorbis

USE_X11 =		Yes
CONFIGURE_STYLE =	gnu
CONFIGURE_ENV +=	CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
			LIBS="-pthread"

post-patch:
	@perl -pi -e 's|cp -a|cp -RpP|' ${WRKSRC}/Makefile.in

.include <bsd.port.mk>