[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / maxr

File: [local] / ports / games / maxr / Makefile (download)

Revision 1.12, Wed Jun 15 23:44:13 2011 UTC (12 years, 11 months ago) by yason
Branch: MAIN
Changes since 1.11: +1 -1 lines

fix license, clean plist

# $OpenBSD$

COMMENT =		M.A.X. clone

DISTNAME =		maxr-0.2.6

CATEGORIES =		games x11

HOMEPAGE =		http://www.maxthegame.de

MAINTAINER =		Kirill Bychkov <yason@linklevel.net>

# GPLv2, GNU FDL
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB =		FLAC SDL SDL_mixer SDL_net c iconv m mikmod ogg pthread \
			smpeg sndio stdc++ usbhid vorbis vorbisfile

MASTER_SITES =		http://www.maxr.org/downloads/

LIB_DEPENDS =		audio/libmikmod \
			audio/libogg \
			audio/libvorbis \
			devel/sdl-mixer \
			devel/sdl-net \
			devel/smpeg

CONFIGURE_STYLE =	gnu
CONFIGURE_ENV +=	CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
			LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib" \
			LIBS="-pthread"

post-patch:
	@perl -pi -e 's|cp -a|cp -RpP|' ${WRKSRC}/Makefile.in

.include <bsd.port.mk>