[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / gemrb

File: [local] / ports / games / gemrb / Attic / Makefile (download)

Revision 1.7, Mon May 6 07:20:43 2013 UTC (11 years ago) by kirby
Branch: MAIN
Changes since 1.6: +18 -62 lines

 - Update to 0.8.0
 - Fix build (needs more love with linking libs)
 - merge PFRAG.shared into PLIST
 - add RUN_DEPENDS
 - Correctly install config file
 - sync TODO

# $OpenBSD$

SHARED_ONLY = 		Yes

SHARED_LIBS += 		gemrb_core                0.0

COMMENT =		open-source implementation of Bioware's Infinity Engine

DISTNAME =		gemrb-0.8.0

CATEGORIES =		games emulators x11

HOMEPAGE =		http://gemrb.sourceforge.net/

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=gemrb/}

WANTLIB += SDL SDL_mixer c freetype iconv m pthread stdc++ vorbisfile
WANTLIB += z

MODULES =		devel/cmake lang/python
LIB_DEPENDS =		devel/sdl-mixer \
			graphics/png \
			audio/openal \
			audio/libvorbis \
			${MODPY_LIB_DEPENDS}
RUN_DEPENDS = 		devel/desktop-file-utils

CONFIGURE_ARGS +=	-DCMAKE_BUILD_TYPE=Release \
			-DSYSCONF_DIR=${SYSCONFDIR}/gemrb/ \
			-DEXAMPLE_CONF_DIR=${PREFIX}/share/examples/gemrb/ \
			-DMAN_DIR=${PREFIX}/man/man6 \
			-DDISABLE_WERROR=1

NO_REGRESS =		Yes

.include <bsd.port.mk>