[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / flightgear

File: [local] / ports / games / flightgear / Attic / Makefile (download)

Revision 1.2, Thu Jun 11 14:36:39 2009 UTC (15 years ago) by yason
Branch: MAIN
Changes since 1.1: +5 -2 lines

some LIB_DEPENDS added

# $OpenBSD$
#ONLY_FOR_ARCHS =	???
#NOT_FOR_ARCHS =	???
#SHARED_ONLY =		???
#COMES_WITH =		???
#BROKEN =		openal update?

COMMENT =		flight simulator
# COMMENT-foo =		???	for multi packages

#
# What port/package will be created
#
DISTNAME =		FlightGear-1.9.1
PKGNAME =		${DISTNAME:L}
#PKGNAME-foo =		???	for multi packages

#SHARED_LIBS =		???

CATEGORIES =		games x11

HOMEPAGE =		http://www.flightgear.org/

#MAINTAINER =		???

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

#WANTLIB =		???

MASTER_SITES =		ftp://ftp.de.flightgear.org/pub/fgfs/Source/
MASTER_SITES0 = 	ftp://ftp.kingmont.com/flightsims/flightgear/Source/
#DISTFILES =		???
#EXTRACT_ONLY =		???
#EXTRACT_SUFX =		.tar.Z

#DIST_SUBDIR =		???

#MODULES =		???
#BUILD_DEPENDS =	???
#RUN_DEPENDS =		???
# XXX try freeglut
LIB_DEPENDS =		::audio/freealut \
			::graphics/glut \
			::graphics/osg
#REGRESS_DEPENDS =	???

#MAKE_FLAGS =		???
#MAKE_ENV =		???
#FAKE_FLAGS =		???
#REGRESS_FLAGS =	???

USE_X11 =		Yes
#USE_GMAKE =		Yes
# Programs that uses libtool should use this option,
# unless there is a really good reason not to.
USE_LIBTOOL =		Yes
# Set CONFIGURE_STYLE to value corresponding to some standard configuration
# 	  perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
#	  Module::Build Build.PL)
# 	  gnu [autoconf] [old] [dest]: gnu style configure (old: no
# 	  sysconfdir), (dest: add DESTDIR, does not handle it),
# 	  (autoconf: needed by port, implies gnu)
# 	XXX: cygnus products do NOT use autoconf for making the main
# 		configure from configure.in
# 	  imake [noman]: port uses imake for configuration.
#   	  (noman: no man page installation)
# 	  simple: port has its own configure script
CONFIGURE_STYLE =	gnu
#CONFIGURE_SCRIPT =	??? (if other than configure)
#CONFIGURE_ARGS +=	${CONFIGURE_SHARED}
#CONFIGURE_ENV +=	LIBS=-lopenal

# for gnu stuff
#AUTOCONF_VERSION =	2.61
#AUTOMAKE_VERSION =	??? (defaults to 1.4)
#MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC}

#IS_INTERACTIVE =		Yes
#REGRESS_IS_INTERACTIVE =	Yes

# Assume you have one multiple choice flavor: 1 2 3 and switches a b.
# You would write
#
#FLAVORS =	1 2 3 a b
#FLAVOR ?=
# grab multiple choice value
#CHOICE = ${FLAVOR:L:Na:Nb}
# check that CHOICE is 1 OR 2 OR 3, or error out
#.if ${CHOICE} == "1"
# code for 1
#.elif ${CHOICE} == "2"
# code for 2
#.elif ${CHOICE} == "3"
# code for 3
#.else
#ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
#.endif
# check for switches
#.if ${FLAVOR:L:Ma}
# code for a
#.endif
#.if ${FLAVOR:L:Mb}
# code for b
#.endif

#NO_REGRESS =		Yes

#CFLAGS =		???
#LDFLAGS =		???
#MAKE_FILE =		???
#PKG_ARCH =		???

#ALL_TARGET =		???
#INSTALL_TARGET =	???
#REGRESS_TARGET =	???

.include <bsd.port.mk>