[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / flightgear

Annotation of ports/games/flightgear/Makefile, Revision 1.2

1.1       yason       1: # $OpenBSD$
                      2: #ONLY_FOR_ARCHS =      ???
                      3: #NOT_FOR_ARCHS =       ???
                      4: #SHARED_ONLY =         ???
                      5: #COMES_WITH =          ???
1.2     ! yason       6: #BROKEN =              openal update?
1.1       yason       7:
                      8: COMMENT =              flight simulator
                      9: # COMMENT-foo =                ???     for multi packages
                     10:
                     11: #
                     12: # What port/package will be created
                     13: #
                     14: DISTNAME =             FlightGear-1.9.1
                     15: PKGNAME =              ${DISTNAME:L}
                     16: #PKGNAME-foo =         ???     for multi packages
                     17:
                     18: #SHARED_LIBS =         ???
                     19:
                     20: CATEGORIES =           games x11
                     21:
                     22: HOMEPAGE =             http://www.flightgear.org/
                     23:
                     24: #MAINTAINER =          ???
                     25:
                     26: # GPLv2
                     27: PERMIT_PACKAGE_CDROM = Yes
                     28: PERMIT_PACKAGE_FTP =   Yes
                     29: PERMIT_DISTFILES_CDROM =Yes
                     30: PERMIT_DISTFILES_FTP = Yes
                     31:
                     32: #WANTLIB =             ???
                     33:
                     34: MASTER_SITES =         ftp://ftp.de.flightgear.org/pub/fgfs/Source/
                     35: MASTER_SITES0 =        ftp://ftp.kingmont.com/flightsims/flightgear/Source/
                     36: #DISTFILES =           ???
                     37: #EXTRACT_ONLY =                ???
                     38: #EXTRACT_SUFX =                .tar.Z
                     39:
                     40: #DIST_SUBDIR =         ???
                     41:
                     42: #MODULES =             ???
                     43: #BUILD_DEPENDS =       ???
                     44: #RUN_DEPENDS =         ???
1.2     ! yason      45: # XXX try freeglut
        !            46: LIB_DEPENDS =          ::audio/freealut \
        !            47:                        ::graphics/glut \
        !            48:                        ::graphics/osg
1.1       yason      49: #REGRESS_DEPENDS =     ???
                     50:
                     51: #MAKE_FLAGS =          ???
                     52: #MAKE_ENV =            ???
                     53: #FAKE_FLAGS =          ???
                     54: #REGRESS_FLAGS =       ???
                     55:
                     56: USE_X11 =              Yes
                     57: #USE_GMAKE =           Yes
                     58: # Programs that uses libtool should use this option,
                     59: # unless there is a really good reason not to.
                     60: USE_LIBTOOL =          Yes
                     61: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
                     62: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
                     63: #        Module::Build Build.PL)
                     64: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
                     65: #        sysconfdir), (dest: add DESTDIR, does not handle it),
                     66: #        (autoconf: needed by port, implies gnu)
                     67: #      XXX: cygnus products do NOT use autoconf for making the main
                     68: #              configure from configure.in
                     69: #        imake [noman]: port uses imake for configuration.
                     70: #        (noman: no man page installation)
                     71: #        simple: port has its own configure script
                     72: CONFIGURE_STYLE =      gnu
                     73: #CONFIGURE_SCRIPT =    ??? (if other than configure)
                     74: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
                     75: #CONFIGURE_ENV +=      LIBS=-lopenal
                     76:
                     77: # for gnu stuff
                     78: #AUTOCONF_VERSION =    2.61
                     79: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
                     80: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC}
                     81:
                     82: #IS_INTERACTIVE =              Yes
                     83: #REGRESS_IS_INTERACTIVE =      Yes
                     84:
                     85: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
                     86: # You would write
                     87: #
                     88: #FLAVORS =     1 2 3 a b
                     89: #FLAVOR ?=
                     90: # grab multiple choice value
                     91: #CHOICE = ${FLAVOR:L:Na:Nb}
                     92: # check that CHOICE is 1 OR 2 OR 3, or error out
                     93: #.if ${CHOICE} == "1"
                     94: # code for 1
                     95: #.elif ${CHOICE} == "2"
                     96: # code for 2
                     97: #.elif ${CHOICE} == "3"
                     98: # code for 3
                     99: #.else
                    100: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                    101: #.endif
                    102: # check for switches
                    103: #.if ${FLAVOR:L:Ma}
                    104: # code for a
                    105: #.endif
                    106: #.if ${FLAVOR:L:Mb}
                    107: # code for b
                    108: #.endif
                    109:
                    110: #NO_REGRESS =          Yes
                    111:
                    112: #CFLAGS =              ???
                    113: #LDFLAGS =             ???
                    114: #MAKE_FILE =           ???
                    115: #PKG_ARCH =            ???
                    116:
                    117: #ALL_TARGET =          ???
                    118: #INSTALL_TARGET =      ???
                    119: #REGRESS_TARGET =      ???
                    120:
                    121: .include <bsd.port.mk>

CVSweb