[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / flightgear

Annotation of ports/games/flightgear/Makefile, Revision 1.1

1.1     ! yason       1: # $OpenBSD$
        !             2: #ONLY_FOR_ARCHS =      ???
        !             3: #NOT_FOR_ARCHS =       ???
        !             4: #SHARED_ONLY =         ???
        !             5: #COMES_WITH =          ???
        !             6: BROKEN =               openal update?
        !             7:
        !             8: COMMENT =              flight simulator
        !             9: # COMMENT-foo =                ???     for multi packages
        !            10:
        !            11: #
        !            12: # What port/package will be created
        !            13: #
        !            14: DISTNAME =             FlightGear-1.9.1
        !            15: PKGNAME =              ${DISTNAME:L}
        !            16: #PKGNAME-foo =         ???     for multi packages
        !            17:
        !            18: #SHARED_LIBS =         ???
        !            19:
        !            20: CATEGORIES =           games x11
        !            21:
        !            22: HOMEPAGE =             http://www.flightgear.org/
        !            23:
        !            24: #MAINTAINER =          ???
        !            25:
        !            26: # GPLv2
        !            27: PERMIT_PACKAGE_CDROM = Yes
        !            28: PERMIT_PACKAGE_FTP =   Yes
        !            29: PERMIT_DISTFILES_CDROM =Yes
        !            30: PERMIT_DISTFILES_FTP = Yes
        !            31:
        !            32: #WANTLIB =             ???
        !            33:
        !            34: MASTER_SITES =         ftp://ftp.de.flightgear.org/pub/fgfs/Source/
        !            35: MASTER_SITES0 =        ftp://ftp.kingmont.com/flightsims/flightgear/Source/
        !            36: #DISTFILES =           ???
        !            37: #EXTRACT_ONLY =                ???
        !            38: #EXTRACT_SUFX =                .tar.Z
        !            39:
        !            40: #DIST_SUBDIR =         ???
        !            41:
        !            42: #MODULES =             ???
        !            43: #BUILD_DEPENDS =       ???
        !            44: #RUN_DEPENDS =         ???
        !            45: #LIB_DEPENDS =         ???
        !            46: #REGRESS_DEPENDS =     ???
        !            47:
        !            48: #MAKE_FLAGS =          ???
        !            49: #MAKE_ENV =            ???
        !            50: #FAKE_FLAGS =          ???
        !            51: #REGRESS_FLAGS =       ???
        !            52:
        !            53: USE_X11 =              Yes
        !            54: #USE_GMAKE =           Yes
        !            55: # Programs that uses libtool should use this option,
        !            56: # unless there is a really good reason not to.
        !            57: USE_LIBTOOL =          Yes
        !            58: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
        !            59: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
        !            60: #        Module::Build Build.PL)
        !            61: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
        !            62: #        sysconfdir), (dest: add DESTDIR, does not handle it),
        !            63: #        (autoconf: needed by port, implies gnu)
        !            64: #      XXX: cygnus products do NOT use autoconf for making the main
        !            65: #              configure from configure.in
        !            66: #        imake [noman]: port uses imake for configuration.
        !            67: #        (noman: no man page installation)
        !            68: #        simple: port has its own configure script
        !            69: CONFIGURE_STYLE =      gnu
        !            70: #CONFIGURE_SCRIPT =    ??? (if other than configure)
        !            71: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
        !            72: #CONFIGURE_ENV +=      LIBS=-lopenal
        !            73:
        !            74: # for gnu stuff
        !            75: #AUTOCONF_VERSION =    2.61
        !            76: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
        !            77: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC}
        !            78:
        !            79: #IS_INTERACTIVE =              Yes
        !            80: #REGRESS_IS_INTERACTIVE =      Yes
        !            81:
        !            82: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
        !            83: # You would write
        !            84: #
        !            85: #FLAVORS =     1 2 3 a b
        !            86: #FLAVOR ?=
        !            87: # grab multiple choice value
        !            88: #CHOICE = ${FLAVOR:L:Na:Nb}
        !            89: # check that CHOICE is 1 OR 2 OR 3, or error out
        !            90: #.if ${CHOICE} == "1"
        !            91: # code for 1
        !            92: #.elif ${CHOICE} == "2"
        !            93: # code for 2
        !            94: #.elif ${CHOICE} == "3"
        !            95: # code for 3
        !            96: #.else
        !            97: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
        !            98: #.endif
        !            99: # check for switches
        !           100: #.if ${FLAVOR:L:Ma}
        !           101: # code for a
        !           102: #.endif
        !           103: #.if ${FLAVOR:L:Mb}
        !           104: # code for b
        !           105: #.endif
        !           106:
        !           107: #NO_REGRESS =          Yes
        !           108:
        !           109: #CFLAGS =              ???
        !           110: #LDFLAGS =             ???
        !           111: #MAKE_FILE =           ???
        !           112: #PKG_ARCH =            ???
        !           113:
        !           114: #ALL_TARGET =          ???
        !           115: #INSTALL_TARGET =      ???
        !           116: #REGRESS_TARGET =      ???
        !           117:
        !           118: .include <bsd.port.mk>

CVSweb