[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / flare

File: [local] / ports / games / flare / Attic / Makefile (download)

Revision 1.2, Tue May 10 14:05:37 2011 UTC (13 years, 1 month ago) by yason
Branch: MAIN
CVS Tags: flare_0-13
Changes since 1.1: +14 -23 lines

addd wrapper and create do-install

# $OpenBSD$

COMMENT =		engine for isometric-view action roleplaying games

DISTNAME =		flare_src_v013
PKGNAME =		flare-0.13

CATEGORIES =		games

HOMEPAGE =		http://clintbellanger.net/rpg/

MAINTAINER =		Kirill Bychkov <yason@linklevel.net>

# GPLv3, CC-BY-SA 3.0
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

WANTLIB += SDL SDL_image SDL_mixer c m pthread stdc++

MASTER_SITES =		http://flare-engine.googlecode.com/files/
EXTRACT_SUFX =		.zip

MODULES =		devel/cmake
LIB_DEPENDS =		devel/sdl-image \
			devel/sdl-mixer

SEPARATE_BUILD =	concurrent

NO_REGRESS =		Yes

WRKSRC =		${WRKDIST}/build

do-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/flare/
	cd ${WRKDIST} && find . \! \( -name build -or -name src -or -name saves \) -type d \
		-exec ${INSTALL_DATA_DIR} "${PREFIX}/share/flare/{}" \;
	cd ${WRKDIST} && find . \! \( -name \*.cpp -or -name \*.h -or -name \CMake* \) \
		-type f -mindepth 2 -exec ${INSTALL_DATA} "{}" "${PREFIX}/share/flare/{}" \;
	${INSTALL_PROGRAM} ${WRKDIST}/flare ${PREFIX}/share/flare/
	${INSTALL_SCRIPT} ${FILESDIR}/flare ${WRKDIST}/flare.sh
	perl -pi -e 's,%%DATADIR%%,${LOCALBASE}/share/flare/,g' ${WRKDIST}/flare.sh
	${INSTALL_SCRIPT} ${WRKDIST}/flare.sh ${PREFIX}/bin/flare

.include <bsd.port.mk>