[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / flare

Annotation of ports/games/flare/Makefile, Revision 1.4

1.1       yason       1: # $OpenBSD$
                      2:
1.2       yason       3: COMMENT =              engine for isometric-view action roleplaying games
1.1       yason       4:
1.3       yason       5: DISTNAME =             flare_src_v014
                      6: PKGNAME =              flare-0.14
1.1       yason       7:
                      8: CATEGORIES =           games
                      9:
                     10: HOMEPAGE =             http://clintbellanger.net/rpg/
                     11:
1.2       yason      12: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
1.1       yason      13:
1.2       yason      14: # GPLv3, CC-BY-SA 3.0
1.1       yason      15: PERMIT_PACKAGE_CDROM = Yes
                     16: PERMIT_PACKAGE_FTP =   Yes
                     17: PERMIT_DISTFILES_CDROM =Yes
                     18: PERMIT_DISTFILES_FTP = Yes
                     19:
1.2       yason      20: WANTLIB += SDL SDL_image SDL_mixer c m pthread stdc++
1.1       yason      21:
1.3       yason      22: MASTER_SITES =         https://github.com/downloads/clintbellanger/flare/
1.1       yason      23: EXTRACT_SUFX =         .zip
                     24:
                     25: MODULES =              devel/cmake
                     26: LIB_DEPENDS =          devel/sdl-image \
                     27:                        devel/sdl-mixer
                     28:
                     29: NO_REGRESS =           Yes
                     30:
                     31: WRKSRC =               ${WRKDIST}/build
                     32:
1.2       yason      33: do-install:
                     34:        ${INSTALL_DATA_DIR} ${PREFIX}/share/flare/
                     35:        cd ${WRKDIST} && find . \! \( -name build -or -name src -or -name saves \) -type d \
                     36:                -exec ${INSTALL_DATA_DIR} "${PREFIX}/share/flare/{}" \;
                     37:        cd ${WRKDIST} && find . \! \( -name \*.cpp -or -name \*.h -or -name \CMake* \) \
                     38:                -type f -mindepth 2 -exec ${INSTALL_DATA} "{}" "${PREFIX}/share/flare/{}" \;
                     39:        ${INSTALL_PROGRAM} ${WRKDIST}/flare ${PREFIX}/share/flare/
                     40:        ${INSTALL_SCRIPT} ${FILESDIR}/flare ${WRKDIST}/flare.sh
                     41:        perl -pi -e 's,%%DATADIR%%,${LOCALBASE}/share/flare/,g' ${WRKDIST}/flare.sh
                     42:        ${INSTALL_SCRIPT} ${WRKDIST}/flare.sh ${PREFIX}/bin/flare
1.1       yason      43:
                     44: .include <bsd.port.mk>

CVSweb