[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / flare

Annotation of ports/games/flare/Makefile, Revision 1.2

1.1       yason       1: # $OpenBSD$
                      2:
1.2     ! yason       3: COMMENT =              engine for isometric-view action roleplaying games
1.1       yason       4:
                      5: DISTNAME =             flare_src_v013
                      6: PKGNAME =              flare-0.13
                      7:
                      8: CATEGORIES =           games
                      9:
                     10: HOMEPAGE =             http://clintbellanger.net/rpg/
                     11:
1.2     ! yason      12: MAINTAINER =           Kirill Bychkov <yason@linklevel.net>
1.1       yason      13:
1.2     ! yason      14: # GPLv3, CC-BY-SA 3.0
1.1       yason      15: PERMIT_PACKAGE_CDROM = Yes
                     16: PERMIT_PACKAGE_FTP =   Yes
                     17: PERMIT_DISTFILES_CDROM =Yes
                     18: PERMIT_DISTFILES_FTP = Yes
                     19:
1.2     ! yason      20: WANTLIB += SDL SDL_image SDL_mixer c m pthread stdc++
1.1       yason      21:
                     22: MASTER_SITES =         http://flare-engine.googlecode.com/files/
                     23: EXTRACT_SUFX =         .zip
                     24:
                     25: MODULES =              devel/cmake
                     26: LIB_DEPENDS =          devel/sdl-image \
                     27:                        devel/sdl-mixer
                     28:
                     29: SEPARATE_BUILD =       concurrent
                     30:
                     31: NO_REGRESS =           Yes
                     32:
                     33: WRKSRC =               ${WRKDIST}/build
                     34:
1.2     ! yason      35: do-install:
        !            36:        ${INSTALL_DATA_DIR} ${PREFIX}/share/flare/
        !            37:        cd ${WRKDIST} && find . \! \( -name build -or -name src -or -name saves \) -type d \
        !            38:                -exec ${INSTALL_DATA_DIR} "${PREFIX}/share/flare/{}" \;
        !            39:        cd ${WRKDIST} && find . \! \( -name \*.cpp -or -name \*.h -or -name \CMake* \) \
        !            40:                -type f -mindepth 2 -exec ${INSTALL_DATA} "{}" "${PREFIX}/share/flare/{}" \;
        !            41:        ${INSTALL_PROGRAM} ${WRKDIST}/flare ${PREFIX}/share/flare/
        !            42:        ${INSTALL_SCRIPT} ${FILESDIR}/flare ${WRKDIST}/flare.sh
        !            43:        perl -pi -e 's,%%DATADIR%%,${LOCALBASE}/share/flare/,g' ${WRKDIST}/flare.sh
        !            44:        ${INSTALL_SCRIPT} ${WRKDIST}/flare.sh ${PREFIX}/bin/flare
1.1       yason      45:
                     46: .include <bsd.port.mk>

CVSweb