[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / fheroes2

File: [local] / ports / games / fheroes2 / Attic / Makefile (download)

Revision 1.5, Wed Aug 11 09:03:51 2021 UTC (2 years, 9 months ago) by kirby
Branch: MAIN
Changes since 1.4: +14 -17 lines

update to fheroes2-0.9.6
switch to cmake

# $OpenBSD$

COMMENT =		free Heroes2 engine

GH_ACCOUNT = 		ihhub
GH_PROJECT = 		fheroes2
GH_TAGNAME = 		0.9.6

CATEGORIES =		games x11

HOMEPAGE =		https://ihhub.github.io/fheroes2/

MAINTAINER =		Kirill Bychkov <kirby@openbsd.org>

# LGPLv2.1/zlib
PERMIT_PACKAGE =	Yes

WANTLIB += SDL2 SDL2_image SDL2_mixer c m png pthread z
WANTLIB += ${COMPILER_LIBCXX}

MODULES = 		devel/cmake
# C++11
COMPILER = 		base-clang ports-gcc

BUILD_DEPENDS =		devel/gettext,-tools

LIB_DEPENDS =		devel/sdl2-mixer \
			devel/sdl2-image

#MAKE_ENV +=		OS=FreeBSD \
#			PLATFORM=bsd \
#			WITHOUT_XML=1 \
#			WITHOUT_BUNDLED_LIBS=1 \
#			CXX=${CXX} CC=${CC}

NO_TEST =		Yes

#do-install:
#	${INSTALL_DATA_DIR} ${PREFIX}/share/fheroes2
#	${INSTALL_PROGRAM} ${WRKBUILD}/fheroes2 ${PREFIX}/share/fheroes2/
#	${INSTALL_SCRIPT} ${FILESDIR}/fheroes2 ${PREFIX}/bin

.include <bsd.port.mk>