[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / falltergeist

File: [local] / ports / games / falltergeist / Makefile (download)

Revision 1.2, Sun Feb 12 22:18:36 2023 UTC (14 months, 2 weeks ago) by kirby
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +2 -8 lines

update to falltergeist-0.4.0 and cleanup

COMMENT =	Fallout 1/2 engine

GH_ACCOUNT =	falltergeist
GH_PROJECT =	falltergeist
GH_TAGNAME =	0.4.0

CATEGORIES =	games x11

HOMEPAGE =	https://falltergeist.org/

MAINTAINER =	Kirill Bychkov <kirby@openbsd.org>

# GPLv3
PERMIT_PACKAGE =	Yes

WANTLIB += GL GLEW SDL2 SDL2_image SDL2_mixer c m pthread z
WANTLIB += ${COMPILER_LIBCXX}

# c++14
COMPILER = 		base-clang ports-gcc
MODULES =		devel/cmake

BUILD_DEPENDS =		graphics/glm
RUN_DEPENDS =		devel/desktop-file-utils
LIB_DEPENDS =		devel/sdl2-image \
			devel/sdl2-mixer \
			graphics/glew
CONFIGURE_ARGS += 	-DCMAKE_CXX_FLAGS=-I${LOCALBASE}/include

NO_TEST =		Yes

.include <bsd.port.mk>