[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / asc

File: [local] / ports / games / asc / Makefile (download)

Revision 1.8, Fri Aug 10 14:30:45 2012 UTC (11 years, 9 months ago) by kirby
Branch: MAIN
Changes since 1.7: +10 -6 lines

update to 2.5.0.0. still broken due lack of sigc++-1.2

# $OpenBSD$

COMMENT = 		turn based strategy game

DISTNAME = 		asc-2.5.0.0
CATEGORIES = 		games x11

HOMEPAGE = 		http://www.asc-hq.org/

# GPL
PERMIT_PACKAGE_CDROM=   Yes
PERMIT_PACKAGE_FTP=     Yes
PERMIT_DISTFILES_CDROM= Yes
PERMIT_DISTFILES_FTP=   Yes

WANTLIB = 		FLAC SDL X11 Xext Xau Xdmcp Xrandr Xrender c \
			expat freetype iconv jpeg m mikmod ogg png \
			pthread pthread-stubs smpeg sndio speex stdc++ \
			tiff usbhid vorbis vorbisenc vorbisfile xcb z

MASTER_SITES = 		${MASTER_SITE_SOURCEFORGE:=asc-hq/}
EXTRACT_SUFX = 		.tar.bz2

BUILD_DEPENDS = 	archivers/zip

MODULES = 		lang/lua
LIB_DEPENDS = 		archivers/bzip2 \
			devel/boost \
			devel/libsigc++ \
			devel/physfs \
			devel/sdl-image \
			devel/sdl-mixer \
			devel/sdl-sound \
			multimedia/xvidcore \
			x11/wxWidgets

USE_GMAKE = 		Yes

CONFIGURE_STYLE = 	gnu
CONFIGURE_ENV +=	LDFLAGS="-L${LOCALBASE}/lib -lm -lz -lstdc++ -pthread"
#			CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/libpng"

pre-configure:
	@perl -pi -e 's,lua5.1,${MODLUA_DEP},g' ${WRKSRC}/configure

.include <bsd.port.mk>