[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / asc

File: [local] / ports / games / asc / Makefile (download)

Revision 1.7, Fri Mar 4 12:30:43 2011 UTC (13 years, 2 months ago) by yason
Branch: MAIN
Changes since 1.6: +9 -9 lines

update DEPENDS style

# $OpenBSD$

COMMENT = 		turn based strategy game

DISTNAME = 		asc-2.4.0.0
CATEGORIES = 		games x11

HOMEPAGE = 		http://www.asc-hq.org/

# GPL
PERMIT_PACKAGE_CDROM=   Yes
PERMIT_PACKAGE_FTP=     Yes
PERMIT_DISTFILES_CDROM= Yes
PERMIT_DISTFILES_FTP=   Yes

WANTLIB = 		FLAC SDL X11 Xext Xau Xdmcp Xrandr Xrender c \
			expat freetype iconv jpeg m mikmod ogg png \
			pthread pthread-stubs smpeg sndio speex stdc++ \
			tiff usbhid vorbis vorbisenc vorbisfile xcb z

MASTER_SITES = 		${MASTER_SITE_SOURCEFORGE:=asc-hq/}
EXTRACT_SUFX = 		.tar.bz2

BUILD_DEPENDS = 	archivers/zip

LIB_DEPENDS = 		archivers/bzip2 \
			devel/boost \
			sigc.>=2:libsigc++->=1,<2:devel/libsigc++ \
			devel/physfs \
			devel/sdl-image \
			devel/sdl-mixer \
			devel/sdl-sound \
			lang/lua \
			multimedia/xvidcore

USE_GMAKE = 		Yes

CONFIGURE_STYLE = 	gnu
CONFIGURE_ENV =		LDFLAGS="-L${LOCALBASE}/lib -lm -lz -lstdc++ -pthread" \
			CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/libpng" \

.include <bsd.port.mk>