[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / games / asc

File: [local] / ports / games / asc / Makefile (download)

Revision 1.1, Wed Feb 25 14:04:17 2009 UTC (15 years, 2 months ago) by yason
Branch: MAIN

Initial revision

# $OpenBSD$

COMMENT = 	turn based strategy game

DISTNAME = 	asc-2.2.0.0
CATEGORIES = 	games x11

HOMEPAGE = 	http://www.asc-hq.org/

# GPL
PERMIT_PACKAGE_CDROM=   Yes
PERMIT_PACKAGE_FTP=     Yes
PERMIT_DISTFILES_CDROM= Yes
PERMIT_DISTFILES_FTP=   Yes

WANTLIB = 		FLAC SDL X11 Xext Xau Xdmcp Xrandr Xrender c expat \
			freetype iconv jpeg m mikmod ogg png pthread smpeg \
			sndio speex stdc++ tiff usbhid vorbis vorbisenc \
			vorbisfile z

MASTER_SITES = 	${MASTER_SITE_SOURCEFORGE:=asc-hq/}
EXTRACT_SUFX = 	.tar.bz2

LIB_DEPENDS = 	SDL_image::devel/sdl-image \
		SDL_mixer::devel/sdl-mixer \
		SDL_sound::devel/sdl-sound \
		boost_regex::devel/boost \
		bz2::archivers/bzip2 \
		physfs::devel/physfs \
		sigc-1.2::devel/libsigc++
# xvidcore

USE_X11 = 		Yes

CONFIGURE_STYLE = 	gnu
CONFIGURE_ENV +=	LDFLAGS="-L${LOCALBASE}/lib -lm -lz -lstdc++" \
			CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/libpng" \

USE_LIBTOOL=	Yes
USE_GMAKE=	Yes

.include <bsd.port.mk>