[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / devel / ode

File: [local] / ports / devel / ode / Attic / Makefile (download)

Revision 1.7, Wed Feb 11 14:30:20 2009 UTC (15 years, 4 months ago) by yason
Branch: MAIN
Changes since 1.6: +0 -2 lines

patch-configure removed due to ode errors. we should find another solution for -DdDOUBLE warning

# $OpenBSD$

COMMENT =		high performance library for simulating rigid body dynamics
SHARED_LIBS = 		ode 2.0

DISTNAME =		ode-0.11

CATEGORIES =		devel

HOMEPAGE =		http://www.ode.org/

# GPLv2
PERMIT_PACKAGE_CDROM =	Yes
PERMIT_PACKAGE_FTP =	Yes
PERMIT_DISTFILES_CDROM =Yes
PERMIT_DISTFILES_FTP =	Yes

MASTER_SITES =		${MASTER_SITE_SOURCEFORGE:=opende/}

CONFIGURE_STYLE =	gnu
CONFIGURE_ARGS = 	--enable-double-precision \
			--with-trimesh=none \
			${CONFIGURE_SHARED}

WANTLIB = 		m pthread

post-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/ode
	${INSTALL_DATA} ${WRKSRC}/LICENSE.TXT ${PREFIX}/share/doc/ode/LICENSE
	${INSTALL_DATA} ${WRKSRC}/README.txt ${PREFIX}/share/doc/ode/README

.include <bsd.port.mk>