[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / devel / libsigc++

Annotation of ports/devel/libsigc++/Makefile, Revision 1.1.1.1

1.1       kirby       1: # $OpenBSD: Makefile,v 1.19 2009/01/09 17:43:38 naddy Exp $
                      2:
                      3: .if ${MACHINE_ARCH} == "hppa"
                      4: BROKEN=                signal-related bug? any program linked with this hangs
                      5: .endif
                      6:
                      7: COMMENT =              callback framework for C++
                      8:
                      9: DISTNAME =             libsigc++-1.2.7
                     10: SHARED_LIBS=           sigc 2.0
                     11: MODGNU_SHARED_LIBS=    sigc '-no-undefined'
                     12:
                     13: CATEGORIES=    devel
                     14:
                     15: HOMEPAGE=      http://libsigc.sf.net/
                     16: MASTER_SITES=  ${MASTER_SITE_GNOME:=sources/libsigc++/1.2/}
                     17:
                     18: PERMIT_PACKAGE_CDROM=  Yes
                     19:
                     20: WANTLIB = m stdc++
                     21:
                     22: USE_GMAKE =            Yes
                     23: CONFIGURE_STYLE=       gnu
                     24: MODGNU_CONFIG_GUESS_DIRS=      ${WRKSRC}/scripts
                     25:
                     26: BUILD_DEPENDS =        devel/m4
                     27:
                     28: DOCDIR=                ${PREFIX}/share/doc/libsigc++/
                     29:
                     30: post-install:
                     31:        ${INSTALL_DATA_DIR} ${DOCDIR}
                     32: .for i in API FAQ UML conventions diagrams marshal powerusers \
                     33:        requirements riscos signals win32
                     34:        ${INSTALL_DATA} ${WRKSRC}/doc/$i ${DOCDIR}
                     35: .endfor
                     36:
                     37: do-regress:
                     38:        @cd ${WRKSRC}/tests/; ${MAKE} check-TESTS
                     39:
                     40: V=             1.2
                     41: SUBST_VARS=    V
                     42: .include <bsd.port.mk>

CVSweb