[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / devel / libinotify

Annotation of ports/devel/libinotify/Makefile, Revision 1.1

1.1     ! kirby       1: # $OpenBSD: Makefile.template,v 1.68 2013/10/02 07:34:45 ajacoutot Exp $
        !             2: # $FreeBSD/NetBSD: credit FreeBSD/NetBSD if thats where the port came from $
        !             3: # Original from: credit the original author here
        !             4: #
        !             5: #ONLY_FOR_ARCHS =      ???
        !             6: #NOT_FOR_ARCHS =       ???
        !             7: #SHARED_ONLY =         ???
        !             8: #COMES_WITH =          ???
        !             9: #BROKEN =              reason
        !            10:
        !            11: COMMENT =              kevent based inotify
        !            12: # COMMENT-foo =                ???     for multi packages
        !            13:
        !            14: DISTNAME =             libinotify-20120419
        !            15: #PKGNAME =             ???
        !            16:
        !            17: SHARED_LIBS =          inotify 0.0
        !            18:
        !            19: CATEGORIES =           devel
        !            20:
        !            21: #HOMEPAGE =            ???     URL
        !            22:
        !            23: #MAINTAINER =          ???
        !            24:
        !            25: # MIT
        !            26: PERMIT_PACKAGE_CDROM = Yes
        !            27:
        !            28: WANTLIB =              pthread
        !            29:
        !            30: MASTER_SITES =         http://ftp.vim.org/pub/ftp/os/BSD/FreeBSD/ports/local-distfiles/sunpoet/
        !            31: #MASTER_SITES =                ${MASTER_SITE_SOURCEFORGE:=subdir/}
        !            32: #MASTER_SITES =                ${MASTER_SITE_foo:=subdir/}
        !            33: # if more master sites are needed...
        !            34: #MASTER_SITES0 =
        !            35: EXTRACT_SUFX =                 .tar.xz
        !            36:
        !            37: #MODULES =             ???
        !            38: #BUILD_DEPENDS =       ???
        !            39: #RUN_DEPENDS =         ???
        !            40: #LIB_DEPENDS =         ???
        !            41: #TEST_DEPENDS =                ???
        !            42:
        !            43: #MAKE_FLAGS =          ???
        !            44: #MAKE_ENV =            ???
        !            45: #FAKE_FLAGS =          ???
        !            46: #TEST_FLAGS =          ???
        !            47:
        !            48: #SEPARATE_BUILD =      Yes (build in a directory other than WRKSRC)
        !            49: #SEPARATE_BUILD =      flavored (distinct flavors may share a common WRKSRC)
        !            50: #USE_GROFF =           Yes
        !            51: #USE_LIBTOOL=          gnu
        !            52: CONFIGURE_STYLE =      automake
        !            53: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
        !            54: #CONFIGURE_ENV =       ???
        !            55:
        !            56: # for gnu stuff
        !            57: AUTOCONF_VERSION =     2.63
        !            58: AUTOMAKE_VERSION =     1.10
        !            59: # config.guess and others are copied here
        !            60: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC})
        !            61:
        !            62: #IS_INTERACTIVE =              Yes
        !            63: #TEST_IS_INTERACTIVE =         Yes
        !            64:
        !            65: #NO_BUILD =            Yes
        !            66: #NO_TEST =             Yes
        !            67:
        !            68: #CFLAGS =              ???
        !            69: #LDFLAGS =             ???
        !            70: #MAKE_FILE =           ???
        !            71: #PKG_ARCH =            ??? (* for arch-independent packages)
        !            72: #WRKDIST =             ??? if other than ${WRKDIR}/${DISTNAME}
        !            73: #WRKSRC =              ??? if other than ${WRKDIST}
        !            74: #WRKBUILD =            ??? if other than ${WRKSRC}
        !            75: #WRKCONF =             ??? if other than ${WRKBUILD}
        !            76:
        !            77: #ALL_TARGET =          ???
        !            78: #INSTALL_TARGET =      ???
        !            79: #TEST_TARGET =         ???
        !            80:
        !            81: pre-configure:
        !            82:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
        !            83:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} libtoolize --force --copy
        !            84:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
        !            85:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} aclocal --force
        !            86:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
        !            87:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoheader -f
        !            88:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
        !            89:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} automake --add-missing
        !            90:        cd ${WRKSRC} && env AUTOCONF_VERSION=${AUTOCONF_VERSION} \
        !            91:                AUTOMAKE_VERSION=${AUTOMAKE_VERSION} autoconf -f
        !            92:
        !            93: .include <bsd.port.mk>

CVSweb