[BACK]Return to Makefile CVS log [TXT][DIR] Up to [local] / ports / cad / qucs

Annotation of ports/cad/qucs/Makefile, Revision 1.1.1.1

1.1       yason       1: # $OpenBSD: Makefile.template,v 1.55 2008/08/23 15:28:00 ajacoutot Exp $
                      2: #ONLY_FOR_ARCHS =      ???
                      3: #NOT_FOR_ARCHS =       ???
                      4: #SHARED_ONLY =         ???
                      5: #COMES_WITH =          ???
                      6: #BROKEN =              reason
                      7:
                      8: COMMENT =              integrated circuit simulator
                      9:
                     10: DISTNAME =             qucs-0.0.15
                     11:
                     12: #SHARED_LIBS =         ???
                     13:
                     14: CATEGORIES =           cad
                     15:
                     16: HOMEPAGE =             http://qucs.sourceforge.net/
                     17:
                     18: #MAINTAINER =          ???
                     19:
                     20: # GPLv2
                     21: PERMIT_PACKAGE_CDROM = Yes
                     22: PERMIT_PACKAGE_FTP =   Yes
                     23: PERMIT_DISTFILES_CDROM =Yes
                     24: PERMIT_DISTFILES_FTP = Yes
                     25:
                     26: MASTER_SITES =         ${MASTER_SITE_SOURCEFORGE:=qucs/}
                     27:
                     28: WANTLIB =              ICE SM X11 c m pthread stdc++
                     29:
                     30: MODULES =              x11/qt3
                     31: #BUILD_DEPENDS =       ???
                     32: #RUN_DEPENDS =         ???
                     33: #LIB_DEPENDS =         ???
                     34: #REGRESS_DEPENDS =     ???
                     35:
                     36: #MAKE_FLAGS =          ???
                     37: #MAKE_ENV =            ???
                     38: #FAKE_FLAGS =          ???
                     39: #REGRESS_FLAGS =       ???
                     40:
                     41: #SEPARATE_BUILD =      concurrent  (build simultaneously on all arches)
                     42: #SEPARATE_BUILD =      simple  (configure/build still recreates files in source)
                     43: USE_X11 =              Yes
                     44: USE_GMAKE =            Yes
                     45: # Programs that uses libtool should use this option,
                     46: # unless there is a really good reason not to.
                     47: #USE_LIBTOOL =         Yes
                     48: # Set CONFIGURE_STYLE to value corresponding to some standard configuration
                     49: #        perl [modbuild]: perl's MakeMaker Makefile.PL (modbuild: perl's
                     50: #        Module::Build Build.PL)
                     51: #        gnu [autoconf] [old] [dest]: gnu style configure (old: no
                     52: #        sysconfdir), (dest: add DESTDIR, does not handle it),
                     53: #        (autoconf: needed by port, implies gnu)
                     54: #      XXX: cygnus products do NOT use autoconf for making the main
                     55: #              configure from configure.in
                     56: #        imake [noman]: port uses imake for configuration.
                     57: #        (noman: no man page installation)
                     58: #        simple: port has its own configure script
                     59: CONFIGURE_STYLE =      gnu
                     60: #CONFIGURE_SCRIPT =    ??? (if other than configure)
                     61: #CONFIGURE_ARGS +=     ${CONFIGURE_SHARED}
                     62: CONFIGURE_ENV =        CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
                     63:                        LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib -pthread"
                     64:
                     65: # for gnu stuff
                     66: #AUTOCONF_VERSION =    ??? (defaults to 2.13)
                     67: #AUTOMAKE_VERSION =    ??? (defaults to 1.4)
                     68: #MODGNU_CONFIG_GUESS_DIRS = ??? (defaults to ${WRKSRC}
                     69:
                     70: # Is the build automagic or is it interactive
                     71: #
                     72: #IS_INTERACTIVE =              Yes
                     73: #REGRESS_IS_INTERACTIVE =      Yes
                     74:
                     75: # Assume you have one multiple choice flavor: 1 2 3 and switches a b.
                     76: # You would write
                     77: #
                     78: #FLAVORS =     1 2 3 a b
                     79: #FLAVOR ?=
                     80: # grab multiple choice value
                     81: #CHOICE = ${FLAVOR:L:Na:Nb}
                     82: # check that CHOICE is 1 OR 2 OR 3, or error out
                     83: #.if ${CHOICE} == "1"
                     84: # code for 1
                     85: #.elif ${CHOICE} == "2"
                     86: # code for 2
                     87: #.elif ${CHOICE} == "3"
                     88: # code for 3
                     89: #.else
                     90: #ERRORS += "Fatal: Conflicting flavor: ${FLAVOR}"
                     91: #.endif
                     92: # check for switches
                     93: #.if ${FLAVOR:L:Ma}
                     94: # code for a
                     95: #.endif
                     96: #.if ${FLAVOR:L:Mb}
                     97: # code for b
                     98: #.endif
                     99:
                    100: # Things that we don't want to do for this port/package
                    101: # Generally, DON'T set anything to No if it's not needed.
                    102: # The time gained is not worth it.
                    103: #
                    104: #NO_BUILD =            Yes
                    105: #NO_REGRESS =          Yes
                    106:
                    107: # Overrides for default values
                    108: #
                    109: #CFLAGS =              ???
                    110: #LDFLAGS =             ???
                    111: #MAKE_FILE =           ???
                    112: #PKG_ARCH =            ???
                    113: #WRKDIST =             ??? if other than ${WRKDIR}/$DISTNAME
                    114: #WRKSRC =              ??? if other than ${WRKDIST}
                    115: #WRKBUILD =            ??? if other than ${WRKSRC}
                    116: #WRKCONF =             ??? if other than ${WRKBUILD}
                    117:
                    118: #ALL_TARGET =          ???
                    119: #INSTALL_TARGET =      ???
                    120: #REGRESS_TARGET =      ???
                    121:
                    122: .include <bsd.port.mk>

CVSweb